summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-06-10 12:43:46 +0200
committerJeroen Roovers <jer@gentoo.org>2017-06-10 12:57:16 +0200
commit59f08eb272e2a48fc12291c98864ec2ab6e4c2e4 (patch)
tree3459f5f7fb670e632f54a9d8a73632a2300bbcfb /net-analyzer/netselect/netselect-0.4.ebuild
parentx11-themes/qtcurve: add snapshot (diff)
downloadgentoo-59f08eb272e2a48fc12291c98864ec2ab6e4c2e4.tar.gz
gentoo-59f08eb272e2a48fc12291c98864ec2ab6e4c2e4.tar.bz2
gentoo-59f08eb272e2a48fc12291c98864ec2ab6e4c2e4.zip
net-analyzer/netselect: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-analyzer/netselect/netselect-0.4.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-0.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-0.4.ebuild b/net-analyzer/netselect/netselect-0.4.ebuild
new file mode 100644
index 000000000000..c28ca36f4c5b
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping"
+HOMEPAGE="http://apenwarr.ca/netselect/"
+SRC_URI="https://github.com/apenwarr/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-bsd.patch
+ "${FILESDIR}"/${PN}-0.4-flags.patch
+)
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ default
+
+ rm -r netinet || die
+
+ tc-export CC
+}
+
+src_install () {
+ dobin netselect
+
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
+
+ dodoc HISTORY README
+
+ doman netselect.1
+}