summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-03-11 08:59:29 +0100
committerJeroen Roovers <jer@gentoo.org>2020-03-11 09:01:52 +0100
commitf180e5bb44285605387096636a82d957472b7481 (patch)
treecb097a52ad13514964a45dd1013405ffcdf0ebcc /net-analyzer/nfdump/files
parentmedia-gfx/krita: keyword on ~ppc64 (diff)
downloadgentoo-f180e5bb44285605387096636a82d957472b7481.tar.gz
gentoo-f180e5bb44285605387096636a82d957472b7481.tar.bz2
gentoo-f180e5bb44285605387096636a82d957472b7481.zip
net-analyzer/nfdump: Version 1.6.19
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=710314 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/nfdump/files')
-rw-r--r--net-analyzer/nfdump/files/nfdump-1.6.19-compiler.patch21
-rw-r--r--net-analyzer/nfdump/files/nfdump-1.6.19-libft.patch17
2 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/nfdump/files/nfdump-1.6.19-compiler.patch b/net-analyzer/nfdump/files/nfdump-1.6.19-compiler.patch
new file mode 100644
index 000000000000..8826c50c9dc2
--- /dev/null
+++ b/net-analyzer/nfdump/files/nfdump-1.6.19-compiler.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,8 +9,6 @@
+ AM_INIT_AUTOMAKE([subdir-objects])
+
+ # Checks for programs.
+-CFLAGS="-g -O3"
+-AC_PROG_CC([clang gcc])
+ AX_CHECK_C11
+ CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wmissing-noreturn -fno-strict-aliasing"
+
+--- a/bin/Makefile.am
++++ b/bin/Makefile.am
+@@ -30,7 +30,6 @@
+ LDADD = $(DEPS_LIBS)
+
+ #Add extra debug info for gdb
+-AM_CFLAGS = -ggdb
+
+ # libnfdump sources
+ output = output_util.h output_util.c output_raw.h output_raw.c
diff --git a/net-analyzer/nfdump/files/nfdump-1.6.19-libft.patch b/net-analyzer/nfdump/files/nfdump-1.6.19-libft.patch
new file mode 100644
index 000000000000..47953c772172
--- /dev/null
+++ b/net-analyzer/nfdump/files/nfdump-1.6.19-libft.patch
@@ -0,0 +1,17 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -115,12 +115,8 @@
+ if test ! -f "$WHERE_FTPATH/include/ftlib.h"; then
+ AC_MSG_ERROR(ftlib.h file not found in flow-tools directory '$WHERE_FTPATH'. Use --with-ftpath=PATH)
+ fi
+- if test -f "$WHERE_FTPATH/lib/libft.a" -o -f "$WHERE_FTPATH/lib64/libft.a" -o -f "$WHERE_FTPATH/lib/libft.so" -o -f "$WHERE_FTPATH/lib64/libft.so"; then
+- FT_INCLUDES="-I$WHERE_FTPATH/include -I$WHERE_FTPATH/lib"
+- FT_LDFLAGS="-L$WHERE_FTPATH/lib"
+- else
+- AC_MSG_ERROR(libft.a not found in flow-tools directory '$WHERE_FTPATH'. Build flow tools first)
+- fi
++ AC_CHECK_LIB([ft], [main],,
++ AC_MSG_ERROR(libft not found in flow-tools directory '$WHERE_FTPATH'. Build flow tools first))
+ else
+ AC_MSG_ERROR(flow-tools directory '$WHERE_FTPATH' does not exists. Use --with-ftpath=PATH)
+ fi