summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-12-12 16:36:12 +0100
committerJeroen Roovers <jer@gentoo.org>2017-12-12 16:36:29 +0100
commit65b9e956aecf309c5b57b61699c3ee4e6180b439 (patch)
tree83370e2bf97c41cde2ec31946476b03172007236 /net-analyzer/nfdump/nfdump-1.6.15-r1.ebuild
parentmedia-libs/jbig2dec: [QA] Move patches to a distfile (diff)
downloadgentoo-65b9e956aecf309c5b57b61699c3ee4e6180b439.tar.gz
gentoo-65b9e956aecf309c5b57b61699c3ee4e6180b439.tar.bz2
gentoo-65b9e956aecf309c5b57b61699c3ee4e6180b439.zip
net-analyzer/nfdump: Fix USE=sflow. Install README.md by Hanno Boeck (bug #611998).
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/nfdump/nfdump-1.6.15-r1.ebuild')
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.15-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/nfdump/nfdump-1.6.15-r1.ebuild b/net-analyzer/nfdump/nfdump-1.6.15-r1.ebuild
new file mode 100644
index 000000000000..86fcde96ecd3
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.6.15-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="https://github.com/phaag/nfdump"
+SRC_URI="
+ ${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="compat15 debug ftconv nfprofile nftrack readpcap sflow static-libs"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
+ nfprofile? ( net-analyzer/rrdtool )
+ nftrack? ( net-analyzer/rrdtool )
+ readpcap? ( net-libs/libpcap )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/flex
+ virtual/yacc
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-lang/perl
+"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+ eapply \
+ "${FILESDIR}"/${PN}-1.6.14-libft.patch \
+ "${FILESDIR}"/${PN}-1.6.14-libnfdump.patch
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ # --without-ftconf is not handled well #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfprofile && echo --enable-nfprofile) \
+ $(use nftrack && echo --enable-nftrack) \
+ $(use_enable compat15) \
+ $(use_enable debug devel) \
+ $(use_enable readpcap) \
+ $(use_enable sflow) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}