summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nmapsi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nmapsi')
-rw-r--r--net-analyzer/nmapsi/Manifest2
-rw-r--r--net-analyzer/nmapsi/metadata.xml9
-rw-r--r--net-analyzer/nmapsi/nmapsi-0.4.1.ebuild51
-rw-r--r--net-analyzer/nmapsi/nmapsi-0.4.ebuild44
4 files changed, 106 insertions, 0 deletions
diff --git a/net-analyzer/nmapsi/Manifest b/net-analyzer/nmapsi/Manifest
new file mode 100644
index 000000000000..b410ee56c5f2
--- /dev/null
+++ b/net-analyzer/nmapsi/Manifest
@@ -0,0 +1,2 @@
+DIST nmapsi4-0.4.1.tar.xz 3139252 SHA256 45482842f414179eb1a9ea0ae88fe4a43d59a54341b97a82be605b43cec41c9a SHA512 243e241a80069d9a7ff7c38c6ed12656385f13250ff707ff84f569807916aab11f14c784210d8cb3047519d80691f5068563c50dac18d74ec9bda8c3f320e802 WHIRLPOOL 99fb464e124ed7fbe2822395cf992aa0bdb49a889cdb855a3a7d03c8da394c3c4e5aadd2aeb2ef08c4383fa3ac396c37a7c26798869e455237e0d8d5e5b23ccc
+DIST nmapsi4-0.4.tar.xz 3138364 SHA256 6b4741656712bfc1eab11f242e4e25268fa52b0bb5efc265f981c5a94a321858 SHA512 b88dc36925020d445b5aa177c48152221f46e8ee82516679d055df609223fc8e1025b60a538cdb2ecfc939580bdd7afe42a9d7968e0b0c255c73cf6a04220182 WHIRLPOOL b64840301520c65269626524872bfc726143dfcd8ad1920f03d8ff010034df2bea9266c8d9c568c1c20ff9844f1c568792d6b4937763ccc0e7d8346fb3091c6d
diff --git a/net-analyzer/nmapsi/metadata.xml b/net-analyzer/nmapsi/metadata.xml
new file mode 100644
index 000000000000..c60e84a8334f
--- /dev/null
+++ b/net-analyzer/nmapsi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="google-code">nmapsi4</remote-id>
+ <remote-id type="sourceforge">nmapsi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nmapsi/nmapsi-0.4.1.ebuild b/net-analyzer/nmapsi/nmapsi-0.4.1.ebuild
new file mode 100644
index 000000000000..ffb545d0cd18
--- /dev/null
+++ b/net-analyzer/nmapsi/nmapsi-0.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ca cs de es fr it ru"
+
+inherit cmake-utils l10n
+
+MY_P=${PN}4-${PV}
+
+DESCRIPTION="A Qt4 frontend to nmap"
+HOMEPAGE="http://www.nmapsi4.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ kde? ( kde-base/kdelibs:4 )
+"
+RDEPEND="${DEPEND}
+ >=net-analyzer/nmap-6.00
+ net-dns/bind-tools
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS HACKING NEWS TODO Translation )
+
+src_prepare() {
+ l10n_for_each_disabled_locale_do nmapsi_disable_locale
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build kde KDELIBS)
+ )
+ cmake-utils_src_configure
+}
+
+nmapsi_disable_locale() {
+ sed -i -e "/ts\/${PN}4_${1}\.ts/d" src/CMakeLists.txt || die
+}
diff --git a/net-analyzer/nmapsi/nmapsi-0.4.ebuild b/net-analyzer/nmapsi/nmapsi-0.4.ebuild
new file mode 100644
index 000000000000..1df63c17e8d3
--- /dev/null
+++ b/net-analyzer/nmapsi/nmapsi-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ca cs de es fr it ru"
+
+inherit cmake-utils l10n
+
+MY_P=${PN}4-${PV}
+
+DESCRIPTION="A Qt4 frontend to nmap"
+HOMEPAGE="http://www.nmapsi4.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ kde? ( kde-base/kdelibs:4 )
+"
+RDEPEND="${DEPEND}
+ >=net-analyzer/nmap-6.00
+ net-dns/bind-tools
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=(AUTHORS HACKING NEWS TODO Translation)
+
+src_prepare() {
+ l10n_for_each_disabled_locale_do nmapsi_disable_locale
+}
+
+nmapsi_disable_locale() {
+ sed -i -e "/ts\/${PN}4_${1}\.ts/d" src/CMakeLists.txt || die
+}