summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-12-28 14:10:28 +0100
committerJeroen Roovers <jer@gentoo.org>2019-12-28 14:10:45 +0100
commiteab423ded8cef06c7dc7ef3f3386148db0121c28 (patch)
tree0a3f8eb0f035d7ab1c61a2c4c9770072e412e6ef /net-analyzer/ntopng/ntopng-3.8-r1.ebuild
parentapp-admin/system-config-printer: fix missing dep (diff)
downloadgentoo-eab423ded8cef06c7dc7ef3f3386148db0121c28.tar.gz
gentoo-eab423ded8cef06c7dc7ef3f3386148db0121c28.tar.bz2
gentoo-eab423ded8cef06c7dc7ef3f3386148db0121c28.zip
net-analyzer/ntopng: Set sub-SLOT for net-libs/nDPI
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/ntopng/ntopng-3.8-r1.ebuild')
-rw-r--r--net-analyzer/ntopng/ntopng-3.8-r1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/ntopng-3.8-r1.ebuild b/net-analyzer/ntopng/ntopng-3.8-r1.ebuild
new file mode 100644
index 000000000000..37e007de41ea
--- /dev/null
+++ b/net-analyzer/ntopng/ntopng-3.8-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools user toolchain-funcs
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-db/sqlite:3
+ dev-python/pyzmq
+ dev-lang/luajit:2
+ dev-libs/json-c:=
+ dev-libs/geoip
+ dev-libs/glib:2
+ dev-libs/hiredis
+ dev-libs/libsodium:=
+ dev-libs/libxml2
+ dev-libs/libmaxminddb
+ net-analyzer/rrdtool
+ net-libs/libpcap
+ >=net-libs/nDPI-2.4:=
+ net-misc/curl
+ sys-libs/binutils-libs
+ dev-db/mysql-connector-c:="
+RDEPEND="${DEPEND}
+ dev-db/redis"
+PATCHES=(
+ "${FILESDIR}"/${P}-mysqltool.patch
+ "${FILESDIR}"/${P}-ndpi-includes.patch
+ "${FILESDIR}"/${P}-missing-min.patch
+ "${FILESDIR}"/${P}-ndpi-call.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s/@VERSION@/${PV}.$(date +%y%m%d)/g" -e "s/@SHORT_VERSION@/${PV}/g" < "${S}/configure.seed" > "${S}/configure.ac" > configure.ac
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
+ dodir ${SHARE_NTOPNG_DIR}
+ insinto ${SHARE_NTOPNG_DIR}
+ doins -r httpdocs
+ doins -r scripts
+
+ dodir ${SHARE_NTOPNG_DIR}/third-party
+ insinto ${SHARE_NTOPNG_DIR}/third-party
+ doins -r third-party/i18n.lua-master
+ doins -r third-party/lua-resty-template-master
+
+ exeinto /usr/bin
+ doexe ${PN}
+ doman ${PN}.8
+
+ newinitd "${FILESDIR}/ntopng.init.d" ntopng
+ newconfd "${FILESDIR}/ntopng.conf.d" ntopng
+
+ dodir "/var/lib/ntopng"
+ fowners ntopng "/var/lib/ntopng"
+}
+
+pkg_setup() {
+ enewuser ntopng
+}
+
+pkg_postinst() {
+ elog "ntopng default credentials are user='admin' password='admin'"
+}