summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-04-06 12:30:36 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-04-07 10:31:40 -0500
commit19d49e3700780ece993de9f0a7e418aa09d3a47f (patch)
tree585dde7a0c2c24edb557f433ca6bc809dc2417b9 /net-analyzer/ntopng
parentacct-group/ntopng: group for ntopng (diff)
downloadgentoo-19d49e3700780ece993de9f0a7e418aa09d3a47f.tar.gz
gentoo-19d49e3700780ece993de9f0a7e418aa09d3a47f.tar.bz2
gentoo-19d49e3700780ece993de9f0a7e418aa09d3a47f.zip
net-analyzer/ntopng: bump to 4.2
Bug: https://bugs.gentoo.org/719084 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-analyzer/ntopng')
-rw-r--r--net-analyzer/ntopng/Manifest1
-rw-r--r--net-analyzer/ntopng/files/ntopng-4.2-PKG_CONFIG.patch129
-rw-r--r--net-analyzer/ntopng/files/ntopng-4.2-mysqltool.patch19
-rw-r--r--net-analyzer/ntopng/files/ntopng-4.2-nogit.patch44
-rw-r--r--net-analyzer/ntopng/files/ntopng-4.2-parallel-make.patch16
-rw-r--r--net-analyzer/ntopng/ntopng-4.2.ebuild94
6 files changed, 303 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/Manifest b/net-analyzer/ntopng/Manifest
index b42fe71c99fa..854955fed75f 100644
--- a/net-analyzer/ntopng/Manifest
+++ b/net-analyzer/ntopng/Manifest
@@ -1,2 +1,3 @@
DIST ntopng-3.8.1.tar.gz 33914341 BLAKE2B 3b0df382e938af78d10e71282e863ccb7ba1da3dc7e2bf90b45f1e6e4670052a8c61a16cb8547f119f0dc753a2e31273b41f40aa26919480cbaecf43b6d59742 SHA512 4cb613881e36b435f97dcc25dfaa505d9c552f63ad8334d5c9d47ec06376d47124c65e6d782546d36f6d27b34b037cc73df7129f459f290ac51e270bb7453970
DIST ntopng-4.0.tar.gz 43239175 BLAKE2B 689883685d46d339d61c338607e2164e36903313cdc0e0e2b649acd7468505f72fce75118a2c3ef55e54d942fc5cc3c312efbd46f8e2603bbcfaf206908bce82 SHA512 a278cc5f304e3040b31c691286650a54d61b5587033724c4513dd7372168477d5b0b471a1d2a5c5682034464b022b88e971567a38d836216431ea77bf1ed90c9
+DIST ntopng-4.2.tar.gz 57554819 BLAKE2B a9eaf7ea670dbd9c830696a4b017330e25a82307852a0a85d95ddbb4e32a3123d43eda1b686c359da1fef77e601cd3791dcdf257141e2e1d3ed7974b92edaac8 SHA512 e89ec3f35644ae8bc570d9802ecfadbf0067145e23a589df2032e8781e9c954f4166d3abb650ddafc65e4fbad656730ee1abf9c5273d3e09f8173d423436b8ff
diff --git a/net-analyzer/ntopng/files/ntopng-4.2-PKG_CONFIG.patch b/net-analyzer/ntopng/files/ntopng-4.2-PKG_CONFIG.patch
new file mode 100644
index 000000000000..40d81ad9d2e5
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-4.2-PKG_CONFIG.patch
@@ -0,0 +1,129 @@
+diff --git a/Makefile.in b/Makefile.in
+index 1435357..38209c7 100755
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -44,9 +44,9 @@ LUA_LIB=$(LUA_HOME)/src/liblua.a
+
+ ######
+ LIBRRDTOOL_HOME=${PWD}/third-party/rrdtool-1.4.8
+-HAS_LIBRRDTOOL=$(shell pkg-config --atleast-version=1.4.8 librrd && echo 0)
++HAS_LIBRRDTOOL=$(shell ${PKG_CONFIG} --atleast-version=1.4.8 librrd && echo 0)
+ ifeq ($(HAS_LIBRRDTOOL), 0)
+- LIBRRDTOOL_INC = $(shell pkg-config --cflags librrd)
++ LIBRRDTOOL_INC = $(shell ${PKG_CONFIG} --cflags librrd)
+ LIBRRDTOOL_LIB = @LIBRRD_LD_FLAGS@
+ else
+ LIBRRDTOOL_INC=-I$(LIBRRDTOOL_HOME)/src/
+@@ -74,21 +74,21 @@ SNMP_LIB=@SNMP_LIB@
+ ######
+
+ ifeq (@NEDGE@, 0)
+- HAS_SODIUM=$(shell pkg-config --exists libsodium && echo 0)
++ HAS_SODIUM=$(shell ${PKG_CONFIG} --exists libsodium && echo 0)
+ ifeq ($(HAS_SODIUM), 0)
+- SODIUM_INC = $(shell pkg-config --cflags libsodium)
+- SODIUM_LIB = $(shell pkg-config --libs libsodium)
++ SODIUM_INC = $(shell ${PKG_CONFIG} --cflags libsodium)
++ SODIUM_LIB = $(shell ${PKG_CONFIG} --libs libsodium)
+ else
+ SODIUM_INC=
+ SODIUM_LIB=
+ endif
+
+- HAS_ZEROMQ=$(shell pkg-config --exists libzmq && echo 0)
++ HAS_ZEROMQ=$(shell ${PKG_CONFIG} --exists libzmq && echo 0)
+ ifeq ($(HAS_ZEROMQ), 0)
+- ZEROMQ_INC = $(shell pkg-config --cflags libzmq)
++ ZEROMQ_INC = $(shell ${PKG_CONFIG} --cflags libzmq)
+ ZMQ_STATIC=/usr/local/lib/libzmq.a
+ ifeq ($(wildcard $(ZMQ_STATIC)),)
+- ZEROMQ_LIB = $(shell pkg-config --libs libzmq)
++ ZEROMQ_LIB = $(shell ${PKG_CONFIG} --libs libzmq)
+ else
+ ZEROMQ_LIB = $(ZMQ_STATIC)
+ endif
+@@ -98,9 +98,9 @@ ifeq (@NEDGE@, 0)
+ ZEROMQ_LIB=$(ZEROMQ_HOME)/.libs/libzmq.a
+ endif
+
+- HAS_ZSTD=$(shell pkg-config --exists libzstd && echo 0)
++ HAS_ZSTD=$(shell ${PKG_CONFIG} --exists libzstd && echo 0)
+ ifeq ($(HAS_ZSTD), 0)
+- ZSTD_LIB = $(shell pkg-config --libs libzstd)
++ ZSTD_LIB = $(shell ${PKG_CONFIG} --libs libzstd)
+ endif
+ endif
+
+diff --git a/configure.seed b/configure.seed
+index a321f9b..f1a7740 100644
+--- a/configure.seed
++++ b/configure.seed
+@@ -190,10 +190,10 @@ if test -z "$NDPI_INC" || test -z "$NDPI_LIB" ; then :
+ fi
+ dnl finish: nDPI handling
+
+-pkg-config --exists json-c
++${PKG_CONFIG} --exists json-c
+ if test "$?" -ne 1; then
+- JSON_INC=`pkg-config --cflags json-c`
+- JSON_LIB=`pkg-config --libs json-c`
++ JSON_INC=`${PKG_CONFIG} --cflags json-c`
++ JSON_LIB=`${PKG_CONFIG} --libs json-c`
+ else
+ echo "Please install libjson-c-dev package prerequisite"
+ exit -1
+@@ -211,11 +211,11 @@ dnl> JSON_LIB=$JSON_HOME/libjson-c.a
+ dnl> fi
+ dnl> fi
+
+-pkg-config --exists libssl
++${PKG_CONFIG} --exists libssl
+ if test "$?" -ne 1; then
+ AC_DEFINE_UNQUOTED(NO_SSL_DL, 1, [has openssl])
+- SSL_INC="`pkg-config --cflags libssl` -I/usr/include/openssl"
+- SSL_LIB="`pkg-config --libs libssl` -lssl -lcrypto"
++ SSL_INC="`${PKG_CONFIG} --cflags libssl` -I/usr/include/openssl"
++ SSL_LIB="`${PKG_CONFIG} --libs libssl` -lssl -lcrypto"
+ else
+ dnl Workaround for MacOS Brew
+ if test -d "/usr/local/opt/openssl/lib"; then
+@@ -329,8 +329,8 @@ AC_DEFINE_UNQUOTED(PACKAGE_REVISION, "${GIT_COMMITS}", [Package Revision])
+ AC_DEFINE_UNQUOTED(NTOPNG_GIT_RELEASE, "${GIT_BRANCH}:${GIT_RELEASE}", [GIT Release])
+ AC_DEFINE_UNQUOTED(NTOPNG_GIT_DATE, "${GIT_DATE}", [Last GIT change])
+
+-if test -z `which pkg-config`; then
+- echo "#!/bin/sh\n" > pkg-config
++if test -z `which ${PKG_CONFIG}`; then
++ echo "#!/bin/sh\n" > ${PKG_CONFIG}
+ fi
+
+ if test -f ".git/index"; then
+@@ -362,8 +362,8 @@ DATE=`date +"%Y-%m-%d"`
+
+ if test -d "/usr/include/hiredis"; then
+ AC_DEFINE_UNQUOTED(HAVE_HIREDIS, 1, [Local hiredis package present])
+- HIREDIS_INC="`pkg-config --cflags hiredis` -I/usr/include/hiredis"
+- HIREDIS_LIB="`pkg-config --libs hiredis` -lhiredis"
++ HIREDIS_INC="`${PKG_CONFIG} --cflags hiredis` -I/usr/include/hiredis"
++ HIREDIS_LIB="`${PKG_CONFIG} --libs hiredis` -lhiredis"
+ else
+ HIREDIS_INC="-I ${PWD}/third-party/hiredis"
+ fi
+@@ -490,7 +490,7 @@ if test x$UGLIFYJS != x; then
+ UGLIFYJS_MAJOR_VERSION="${UGLIFYJS_VERSION%%.*}"
+ fi
+
+-AC_CHECK_LIB([rrd_th], [rrd_update_r], [LIBRRD_LD_FLAGS=-lrrd_th], [LIBRRD_LD_FLAGS=`pkg-config --libs librrd`])
++AC_CHECK_LIB([rrd_th], [rrd_update_r], [LIBRRD_LD_FLAGS=-lrrd_th], [LIBRRD_LD_FLAGS=`${PKG_CONFIG} --libs librrd`])
+
+ AC_CHECK_LIB([nl], [nl_handle_alloc], [LDFLAGS="${LDFLAGS} -lnl"])
+ AC_CHECK_LIB([rt], [clock_gettime], [LDFLAGS="${LDFLAGS} -lrt"])
+@@ -509,7 +509,7 @@ else
+ dnl> https://github.com/curl/curl/blob/curl-7_20_0/TODO-RELEASE
+
+ AC_MSG_CHECKING(for curl SMTP support)
+- if `pkg-config --atleast-version="7.20.0" libcurl` ; then
++ if `${PKG_CONFIG} --atleast-version="7.20.0" libcurl` ; then
+ AC_DEFINE_UNQUOTED(HAVE_CURL_SMTP, 1, [curl supports SMTP])
+ AC_MSG_RESULT(yes)
+ else
diff --git a/net-analyzer/ntopng/files/ntopng-4.2-mysqltool.patch b/net-analyzer/ntopng/files/ntopng-4.2-mysqltool.patch
new file mode 100644
index 000000000000..a961bc28902f
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-4.2-mysqltool.patch
@@ -0,0 +1,19 @@
+diff --git a/configure.seed b/configure.seed
+index a321f9b..9f0f1cc 100644
+--- a/configure.seed
++++ b/configure.seed
+@@ -596,13 +596,7 @@ if test "${with_nedge+set}" != set; then
+ if test "x$ac_cv_prog_ac_ct_MARIADB" = "xmariadb_config"; then
+ MYSQLTOOL="mariadb_config"
+ else
+- PATH=$PATH:/usr/local/mysql/bin
+- AC_CHECK_TOOL(MYSQL, mysql_config)
+- if test "x$ac_cv_prog_ac_ct_MYSQL" = "xmysql_config"; then
+- MYSQLTOOL="mysql_config"
+- else
+- MYSQLTOOL=""
+- fi
++ MYSQLTOOL="mysql_config"
+ fi
+
+ if test -n "$MYSQLTOOL"; then
diff --git a/net-analyzer/ntopng/files/ntopng-4.2-nogit.patch b/net-analyzer/ntopng/files/ntopng-4.2-nogit.patch
new file mode 100644
index 000000000000..17b68f0918fb
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-4.2-nogit.patch
@@ -0,0 +1,44 @@
+diff --git a/Makefile.in b/Makefile.in
+index 38209c7..6945ce7 100755
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -171,7 +171,6 @@ $(LIBRRDTOOL_LIB):
+ cd $(LIBRRDTOOL_HOME); ./configure --disable-libdbi --disable-libwrap --disable-rrdcgi --disable-libtool-lock --disable-nls --disable-rpath --disable-perl --disable-ruby --disable-lua --disable-tcl --disable-python --disable-dependency-tracking --disable-rrd_graph ; cd src; @GMAKE@ librrd_th.la
+
+ hooks/.enabled:
+- git config core.hooksPath hooks || true
+ touch hooks/.enabled
+
+ clean:
+diff --git a/configure.seed b/configure.seed
+index 7e2eced..dd3257d 100644
+--- a/configure.seed
++++ b/configure.seed
+@@ -77,7 +77,6 @@ fi
+ # On CentOS 6 `git rev-list HEAD --count` does not work
+ #
+ #
+-REVISION=`git log --pretty=oneline | wc -l`
+
+ if test -d "/usr/local/include"; then
+ CFLAGS="${CFLAGS} -I/usr/local/include"
+@@ -323,7 +322,6 @@ else
+ AC_MSG_RESULT(not found)
+ fi
+
+-GIT_COMMITS=`git rev-list --all |wc -l | tr -d '[[:space:]]'`
+ AC_DEFINE_UNQUOTED(PACKAGE_REVISION, "${GIT_COMMITS}", [Package Revision])
+
+ AC_DEFINE_UNQUOTED(NTOPNG_GIT_RELEASE, "${GIT_BRANCH}:${GIT_RELEASE}", [GIT Release])
+@@ -671,11 +669,6 @@ AC_DEFINE_UNQUOTED(_CRT_SECURE_NO_WARNINGS, 1, [Disable warning on windows])
+
+ GMAKE='$(MAKE)'
+
+-GIT=`which git`
+-if test x$GIT = x; then
+- AC_MSG_RESULT(FATAL ERROR: git is not installed on your host)
+-fi
+-
+ WGET=`which wget`
+ if test x$WGET = x; then
+ AC_MSG_RESULT(ERROR. wget is not installed on your host: you cannot download GeoIP data)
diff --git a/net-analyzer/ntopng/files/ntopng-4.2-parallel-make.patch b/net-analyzer/ntopng/files/ntopng-4.2-parallel-make.patch
new file mode 100644
index 000000000000..b3086284a5a9
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-4.2-parallel-make.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.seed b/configure.seed
+index a321f9b..d27d35d 100644
+--- a/configure.seed
++++ b/configure.seed
+@@ -675,10 +675,7 @@ fi
+
+ AC_DEFINE_UNQUOTED(_CRT_SECURE_NO_WARNINGS, 1, [Disable warning on windows])
+
+-GMAKE=`which gmake`
+-if test x$GMAKE = x; then
+- GMAKE="make"
+-fi
++GMAKE='$(MAKE)'
+
+ GIT=`which git`
+ if test x$GIT = x; then
diff --git a/net-analyzer/ntopng/ntopng-4.2.ebuild b/net-analyzer/ntopng/ntopng-4.2.ebuild
new file mode 100644
index 000000000000..de038c42e391
--- /dev/null
+++ b/net-analyzer/ntopng/ntopng-4.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-db/mysql-connector-c:=
+ dev-db/sqlite:3
+ dev-libs/hiredis:=
+ dev-libs/json-c:=
+ dev-libs/libmaxminddb
+ dev-libs/libsodium:=
+ dev-libs/openssl
+ net-analyzer/rrdtool
+ net-libs/libpcap
+ >=net-libs/nDPI-3.0:=
+ >=net-libs/zeromq-3:=
+ net-misc/curl
+ sys-libs/libcap
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ acct-user/ntopng
+ acct-group/ntopng
+ dev-db/redis"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2-mysqltool.patch"
+ "${FILESDIR}/${PN}-4.2-parallel-make.patch"
+ "${FILESDIR}/${PN}-4.0-ndpi-includes.patch"
+ "${FILESDIR}/${PN}-4.2-PKG_CONFIG.patch"
+ "${FILESDIR}/${PN}-4.2-nogit.patch"
+)
+
+src_prepare() {
+ default
+
+ # Follows upstream's autogen.sh
+ sed \
+ -e "s/@VERSION@/${PV}.$(date +%y%m%d)/g" \
+ -e "s/@SHORT_VERSION@/${PV}/g" \
+ -e "s/@GIT_DATE@/$(date)/g" \
+ -e "s/@GIT_RELEASE@/${PV}.$(date +%y%m%d)/g" \
+ -e "s/@GIT_BRANCH@//g" < "${S}/configure.seed" \
+ > "${S}/configure.ac" || die
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ MYCFLAGS="${CFLAGS}" \
+ MYLDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
+ insinto "${SHARE_NTOPNG_DIR}"
+ doins -r httpdocs
+ doins -r scripts
+
+ insinto "${SHARE_NTOPNG_DIR}/third-party"
+ doins -r third-party/i18n.lua-master
+ doins -r third-party/lua-resty-template-master
+
+ exeinto /usr/bin
+ doexe "${PN}"
+ doman "${PN}.8"
+
+ newinitd "${FILESDIR}"/ntopng.init.d ntopng
+ newconfd "${FILESDIR}"/ntopng.conf.d ntopng
+
+ keepdir /var/lib/ntopng
+ fowners ntopng /var/lib/ntopng
+}
+
+pkg_postinst() {
+ elog "ntopng default credentials are user='admin' password='admin'"
+}