summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-03 11:20:05 +0000
committerSam James <sam@gentoo.org>2022-01-03 11:21:21 +0000
commit39868efcc6779ea5e5272c3434e4a59f0bae9aa1 (patch)
tree8cf69a3cf4b9851c059dbf5e14c2bb57ff418a7f /net-analyzer/ntopng
parentnet-libs/nDPI: add 4.0 (diff)
downloadgentoo-39868efcc6779ea5e5272c3434e4a59f0bae9aa1.tar.gz
gentoo-39868efcc6779ea5e5272c3434e4a59f0bae9aa1.tar.bz2
gentoo-39868efcc6779ea5e5272c3434e4a59f0bae9aa1.zip
net-analyzer/ntopng: add 5.0
As with nDPI, aware of the ar-directly and other similar bugs, but am trying to address this first upstream & go from there. Bug: https://bugs.gentoo.org/799782 Bug: https://bugs.gentoo.org/830403 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/ntopng')
-rw-r--r--net-analyzer/ntopng/Manifest1
-rw-r--r--net-analyzer/ntopng/ntopng-5.0.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/Manifest b/net-analyzer/ntopng/Manifest
index 29da3cb09be7..9a94093e2365 100644
--- a/net-analyzer/ntopng/Manifest
+++ b/net-analyzer/ntopng/Manifest
@@ -1 +1,2 @@
DIST ntopng-4.2.tar.gz 57554819 BLAKE2B a9eaf7ea670dbd9c830696a4b017330e25a82307852a0a85d95ddbb4e32a3123d43eda1b686c359da1fef77e601cd3791dcdf257141e2e1d3ed7974b92edaac8 SHA512 e89ec3f35644ae8bc570d9802ecfadbf0067145e23a589df2032e8781e9c954f4166d3abb650ddafc65e4fbad656730ee1abf9c5273d3e09f8173d423436b8ff
+DIST ntopng-5.0.tar.gz 57935381 BLAKE2B 420bda10ecc264d6baea0714367e8c475e72480ab1a114251c6712535ad1415288154623aa3ef780a5bab55bec684ddd7c0582997654f8fbb96ec08e17cb099f SHA512 e157430d9c98871d0136d2f51af6c7fed3a95fa21f8d3a9447ee69ac2aaee3752b6eddfd584715e3ee36234fd0fdcf865b761b0ec1a08727f6d988bc115d21e6
diff --git a/net-analyzer/ntopng/ntopng-5.0.ebuild b/net-analyzer/ntopng/ntopng-5.0.ebuild
new file mode 100644
index 000000000000..e879c8456307
--- /dev/null
+++ b/net-analyzer/ntopng/ntopng-5.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-db/mysql-connector-c:=
+ dev-db/sqlite:3
+ dev-libs/hiredis:=
+ dev-libs/json-c:=
+ dev-libs/libmaxminddb
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+ net-analyzer/rrdtool
+ net-libs/libpcap
+ >=net-libs/nDPI-3.0:=
+ >=net-libs/zeromq-3:=
+ net-misc/curl
+ sys-libs/libcap
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ acct-user/ntopng
+ acct-group/ntopng
+ dev-db/redis"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2-mysqltool.patch
+ "${FILESDIR}"/${PN}-4.2-parallel-make.patch
+ "${FILESDIR}"/${PN}-4.0-ndpi-includes.patch
+)
+
+src_prepare() {
+ default
+
+ # Follows upstream's autogen.sh
+ sed \
+ -e "s/@VERSION@/${PV}.$(date +%y%m%d)/g" \
+ -e "s/@SHORT_VERSION@/${PV}/g" \
+ -e "s/@GIT_DATE@/$(date)/g" \
+ -e "s/@GIT_RELEASE@/${PV}.$(date +%y%m%d)/g" \
+ -e "s/@GIT_BRANCH@//g" < "${S}/configure.seed" \
+ > "${S}/configure.ac" || die
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ MYCFLAGS="${CFLAGS}" \
+ MYLDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
+ insinto "${SHARE_NTOPNG_DIR}"
+ doins -r httpdocs
+ doins -r scripts
+
+ insinto "${SHARE_NTOPNG_DIR}/third-party"
+ doins -r third-party/i18n.lua-master
+ doins -r third-party/lua-resty-template-master
+
+ exeinto /usr/bin
+ doexe "${PN}"
+ doman "${PN}.8"
+
+ newinitd "${FILESDIR}"/ntopng.init.d ntopng
+ newconfd "${FILESDIR}"/ntopng.conf.d ntopng
+
+ keepdir /var/lib/ntopng
+ fowners ntopng /var/lib/ntopng
+}
+
+pkg_postinst() {
+ elog "ntopng default credentials are user='admin' password='admin'"
+}