summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-27 00:24:38 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-27 00:25:26 +0000
commitd35b20af0e1326b05b0ea2e30f0b91934c01fa90 (patch)
treee32090c4618e83b5ca67f27abcb0f29497e47161 /net-analyzer/ntopng
parentmedia-gfx/graphicsmagick: bump to 1.3.36 (diff)
downloadgentoo-d35b20af0e1326b05b0ea2e30f0b91934c01fa90.tar.gz
gentoo-d35b20af0e1326b05b0ea2e30f0b91934c01fa90.tar.bz2
gentoo-d35b20af0e1326b05b0ea2e30f0b91934c01fa90.zip
net-analyzer/ntopng: remove 3.8-r1
The oldest of the three versions currently in the tree and the only one to actually depend on Lua. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-analyzer/ntopng')
-rw-r--r--net-analyzer/ntopng/files/ntopng-3.8-missing-min.patch19
-rw-r--r--net-analyzer/ntopng/files/ntopng-3.8-ndpi-call.patch12
-rw-r--r--net-analyzer/ntopng/ntopng-3.8-r1.ebuild76
3 files changed, 0 insertions, 107 deletions
diff --git a/net-analyzer/ntopng/files/ntopng-3.8-missing-min.patch b/net-analyzer/ntopng/files/ntopng-3.8-missing-min.patch
deleted file mode 100644
index 303826a918df..000000000000
--- a/net-analyzer/ntopng/files/ntopng-3.8-missing-min.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/third-party/zeromq-4.1.3/src/tcp_connecter.cpp
-+++ b/third-party/zeromq-4.1.3/src/tcp_connecter.cpp
-@@ -31,6 +31,7 @@
-
- #include <new>
- #include <string>
-+#include <algorithm>
-
- #include "tcp_connecter.hpp"
- #include "stream_engine.hpp"
-@@ -207,7 +208,7 @@
- options.reconnect_ivl_max > options.reconnect_ivl)
- // Calculate the next interval
- current_reconnect_ivl =
-- min (current_reconnect_ivl * 2, options.reconnect_ivl_max);
-+ std::min(current_reconnect_ivl * 2, options.reconnect_ivl_max);
- return interval;
- }
-
diff --git a/net-analyzer/ntopng/files/ntopng-3.8-ndpi-call.patch b/net-analyzer/ntopng/files/ntopng-3.8-ndpi-call.patch
deleted file mode 100644
index 1308a5c2c03f..000000000000
--- a/net-analyzer/ntopng/files/ntopng-3.8-ndpi-call.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/NetworkInterface.cpp
-+++ b/src/NetworkInterface.cpp
-@@ -1604,7 +1604,8 @@
- ndpi_protocol icmp_proto = flow->get_detected_protocol();
-
- if(icmp_proto.category == NDPI_PROTOCOL_CATEGORY_UNSPECIFIED) {
-- ndpi_fill_ip_protocol_category(ndpi_struct, (struct ndpi_iphdr *)ip, &icmp_proto);
-+ ndpi_fill_ip_protocol_category(ndpi_struct, ((struct ndpi_iphdr *)ip)->saddr,
-+ ((struct ndpi_iphdr*)ip)->daddr, &icmp_proto);
- flow->setDetectedProtocol(icmp_proto, false);
- }
- }
diff --git a/net-analyzer/ntopng/ntopng-3.8-r1.ebuild b/net-analyzer/ntopng/ntopng-3.8-r1.ebuild
deleted file mode 100644
index 37e007de41ea..000000000000
--- a/net-analyzer/ntopng/ntopng-3.8-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools user toolchain-funcs
-
-DESCRIPTION="Network traffic analyzer with web interface"
-HOMEPAGE="https://www.ntop.org/"
-SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-db/sqlite:3
- dev-python/pyzmq
- dev-lang/luajit:2
- dev-libs/json-c:=
- dev-libs/geoip
- dev-libs/glib:2
- dev-libs/hiredis
- dev-libs/libsodium:=
- dev-libs/libxml2
- dev-libs/libmaxminddb
- net-analyzer/rrdtool
- net-libs/libpcap
- >=net-libs/nDPI-2.4:=
- net-misc/curl
- sys-libs/binutils-libs
- dev-db/mysql-connector-c:="
-RDEPEND="${DEPEND}
- dev-db/redis"
-PATCHES=(
- "${FILESDIR}"/${P}-mysqltool.patch
- "${FILESDIR}"/${P}-ndpi-includes.patch
- "${FILESDIR}"/${P}-missing-min.patch
- "${FILESDIR}"/${P}-ndpi-call.patch
-)
-
-src_prepare() {
- default
- sed -e "s/@VERSION@/${PV}.$(date +%y%m%d)/g" -e "s/@SHORT_VERSION@/${PV}/g" < "${S}/configure.seed" > "${S}/configure.ac" > configure.ac
- eapply_user
- eautoreconf
-}
-
-src_install() {
- SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
- dodir ${SHARE_NTOPNG_DIR}
- insinto ${SHARE_NTOPNG_DIR}
- doins -r httpdocs
- doins -r scripts
-
- dodir ${SHARE_NTOPNG_DIR}/third-party
- insinto ${SHARE_NTOPNG_DIR}/third-party
- doins -r third-party/i18n.lua-master
- doins -r third-party/lua-resty-template-master
-
- exeinto /usr/bin
- doexe ${PN}
- doman ${PN}.8
-
- newinitd "${FILESDIR}/ntopng.init.d" ntopng
- newconfd "${FILESDIR}/ntopng.conf.d" ntopng
-
- dodir "/var/lib/ntopng"
- fowners ntopng "/var/lib/ntopng"
-}
-
-pkg_setup() {
- enewuser ntopng
-}
-
-pkg_postinst() {
- elog "ntopng default credentials are user='admin' password='admin'"
-}