summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/oinkmaster
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/oinkmaster')
-rw-r--r--net-analyzer/oinkmaster/Manifest1
-rw-r--r--net-analyzer/oinkmaster/metadata.xml8
-rw-r--r--net-analyzer/oinkmaster/oinkmaster-2.0.ebuild41
3 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/oinkmaster/Manifest b/net-analyzer/oinkmaster/Manifest
new file mode 100644
index 000000000000..6b4602e9a42f
--- /dev/null
+++ b/net-analyzer/oinkmaster/Manifest
@@ -0,0 +1 @@
+DIST oinkmaster-2.0.tar.gz 80111 SHA256 3d52f0426aa7c81b122cef22b80d708d8bb8337537e48754a065804f46c46162 SHA512 03874462cff71e558d4383fef9e757eb4260b20f4b1de4741edcd49fec6effe32669e95edb637962b77b12c519deeb74adc3c15427d0e054e1b96e2f03ffdb3b WHIRLPOOL eff3cdce34eaa067eba9217d7fc867a897ba9734577c55eff49499657149cb3f55310bd03342cccabfcf62e1b7418b9ec1962937a355d3d3728efe21be617ef9
diff --git a/net-analyzer/oinkmaster/metadata.xml b/net-analyzer/oinkmaster/metadata.xml
new file mode 100644
index 000000000000..caf45de8548f
--- /dev/null
+++ b/net-analyzer/oinkmaster/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">oinkmaster</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/oinkmaster/oinkmaster-2.0.ebuild b/net-analyzer/oinkmaster/oinkmaster-2.0.ebuild
new file mode 100644
index 000000000000..49b8ef0ec8b4
--- /dev/null
+++ b/net-analyzer/oinkmaster/oinkmaster-2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Rule management for SNORT"
+SRC_URI="mirror://sourceforge/oinkmaster/${P}.tar.gz"
+HOMEPAGE="http://oinkmaster.sf.net/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc sparc x86"
+IUSE="X"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.1
+ X? ( dev-perl/perl-tk )
+ net-misc/wget
+ app-arch/tar
+ app-arch/gzip
+"
+
+src_install() {
+ dobin \
+ contrib/addmsg.pl \
+ contrib/addsid.pl \
+ contrib/create-sidmap.pl \
+ contrib/makesidex.pl \
+ oinkmaster.pl
+
+ use X && dobin contrib/oinkgui.pl
+
+ dodoc FAQ README README.gui README.win32 UPGRADING contrib/README.contrib
+
+ doman oinkmaster.1
+
+ insinto /etc
+ doins oinkmaster.conf
+}