summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2020-03-21 16:15:15 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-25 15:45:27 +0200
commit34e2e746d9d0f2a1f84b57e0297416486b461ddc (patch)
tree8525c3f1273e0ac8d2a0d29aad28403dfce550e0 /net-analyzer/ospd-openvas/ospd-openvas-1.0.0.ebuild
parentacct-group/gvm: overtake maintainership (diff)
downloadgentoo-34e2e746d9d0f2a1f84b57e0297416486b461ddc.tar.gz
gentoo-34e2e746d9d0f2a1f84b57e0297416486b461ddc.tar.bz2
gentoo-34e2e746d9d0f2a1f84b57e0297416486b461ddc.zip
net-analyzer/ospd-openvas: add new package
Bug: https://bugs.gentoo.org/713804 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Closes: https://github.com/gentoo/gentoo/pull/14922 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/ospd-openvas/ospd-openvas-1.0.0.ebuild')
-rw-r--r--net-analyzer/ospd-openvas/ospd-openvas-1.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/ospd-openvas/ospd-openvas-1.0.0.ebuild b/net-analyzer/ospd-openvas/ospd-openvas-1.0.0.ebuild
new file mode 100644
index 000000000000..8c2dfcfee26f
--- /dev/null
+++ b/net-analyzer/ospd-openvas/ospd-openvas-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+inherit distutils-r1 systemd
+
+DESCRIPTION="This is an OSP server implementation to allow GVM to remotely control OpenVAS"
+HOMEPAGE="https://github.com/greenbone/ospd-openvas"
+SRC_URI="https://github.com/greenbone/ospd-openvas/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ acct-user/gvm
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ net-analyzer/ospd[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-analyzer/openvas-scanner-7.0.0"
+BDEPEND=""
+
+distutils_enable_tests unittest
+
+python_install() {
+ distutils-r1_python_install
+
+ insinto /etc/openvas
+ doins "${FILESDIR}"/redis.conf.example
+ doins "${FILESDIR}"/ospd.conf
+
+ fowners -R gvm:gvm /etc/openvas
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}