summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-01-15 12:31:17 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-01-15 12:31:33 -0500
commitfb9a37adac6db645eaa9b788184ca1e41b983153 (patch)
treeda4af756ed75c8c1c58fb8cc0d59d7a4ce9b0b9e /net-analyzer/ostinato/ostinato-0.9.ebuild
parentnet-libs/libpcap: import fix from debian for bug#602098 (diff)
downloadgentoo-fb9a37adac6db645eaa9b788184ca1e41b983153.tar.gz
gentoo-fb9a37adac6db645eaa9b788184ca1e41b983153.tar.bz2
gentoo-fb9a37adac6db645eaa9b788184ca1e41b983153.zip
net-analyzer/ostinato: bump and bug #602098
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/ostinato/ostinato-0.9.ebuild')
-rw-r--r--net-analyzer/ostinato/ostinato-0.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/ostinato/ostinato-0.9.ebuild b/net-analyzer/ostinato/ostinato-0.9.ebuild
new file mode 100644
index 000000000000..fa2db04b283b
--- /dev/null
+++ b/net-analyzer/ostinato/ostinato-0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="A packet generator and analyzer"
+HOMEPAGE="http://ostinato.org/"
+SRC_URI="https://github.com/pstavirs/ostinato/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#https://github.com/pstavirs/ostinato/issues/173
+# libpcap dep is versioned to pull in the fix for #602098
+DEPEND="dev-libs/protobuf:=
+ >=net-libs/libpcap-1.8.1-r2
+ dev-qt/qtscript:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ eqmake4 PREFIX="${ED}/usr" ost.pro
+}