summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/pktstat/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/pktstat/files')
-rw-r--r--net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch46
-rw-r--r--net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch10
2 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch b/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch
new file mode 100644
index 000000000000..67ea9e9181e8
--- /dev/null
+++ b/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch
@@ -0,0 +1,46 @@
+--- a/tcp_smtp.c
++++ b/tcp_smtp.c
+@@ -149,13 +149,9 @@
+ struct smtp_state *state;
+ const char *s;
+ int addr_changed = 0;
+-FILE*log;
+
+ state = (struct smtp_state *)f->udata;
+
+-if ((log = fopen("/tmp/smtp.log", "a")))
+- fprintf(log, "smpt_line [%s]\n", line);
+-
+ if (state->in_data) {
+ if (strcmp(line, ".") == 0) {
+ state->in_data = 0;
+@@ -180,18 +176,15 @@
+ } else {
+ /* Normalize the command line */
+ normalize_line(line);
+-if (log)fprintf(log, "normalized to [%s]\n", line);
+ if ((s = strip_prefix(line, "MAIL FROM:"))) {
+ snprintf(state->from_addr, sizeof state->from_addr, "%s", s);
+ normalize_addr(state->from_addr);
+ addr_changed = 1;
+-if (log)fprintf(log, "from_addr = [%s]\n", state->from_addr);
+ }
+ else if ((s = strip_prefix(line, "RCPT TO:"))) {
+ snprintf(state->to_addr, sizeof state->to_addr, "%s", s);
+ normalize_addr(state->to_addr);
+ addr_changed = 1;
+-if (log)fprintf(log, "to_addr = [%s]\n", state->to_addr);
+ }
+ else if (strcmp(line, "DATA") == 0) {
+ state->in_data = 1;
+@@ -213,10 +206,7 @@
+ if (strcmp(line, "QUIT") != 0)
+ snprintf(f->desc, sizeof f->desc, "%s", line);
+ }
+-if (log)fprintf(log, "set desc to: [%s]\n", f->desc);
+ }
+-
+-if (log)fclose(log);
+ }
+
+ /*
diff --git a/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch b/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch
new file mode 100644
index 000000000000..5181124b8053
--- /dev/null
+++ b/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,6 +18,7 @@
+ AC_SEARCH_LIBS(gethostbyname, [nsl]) dnl for Solaris
+ AC_SEARCH_LIBS(pcap_open_live, [pcap])
+ AC_SEARCH_LIBS(exp, [m])
++PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",AC_MSG_ERROR[ncurses is required])
+ AC_SEARCH_LIBS(tgoto, [termlib termcap curses ncurses ocurses])
+ AC_SEARCH_LIBS(initscr, [curses ncurses ocurses])
+ AC_SEARCH_LIBS(nanosleep, [posix4])