summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-19 07:52:31 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-19 07:57:07 +0100
commit8b4639236d4d4b11089e8fc285514d7602ecc40f (patch)
tree0ced24f6a1299a79b665382fb308867481895a86 /net-analyzer/pypacker/pypacker-4.9.ebuild
parentnet-analyzer/bwping: Version 1.16 (diff)
downloadgentoo-8b4639236d4d4b11089e8fc285514d7602ecc40f.tar.gz
gentoo-8b4639236d4d4b11089e8fc285514d7602ecc40f.tar.bz2
gentoo-8b4639236d4d4b11089e8fc285514d7602ecc40f.zip
net-analyzer/pypacker: Version 4.9
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/pypacker/pypacker-4.9.ebuild')
-rw-r--r--net-analyzer/pypacker/pypacker-4.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/pypacker/pypacker-4.9.ebuild b/net-analyzer/pypacker/pypacker-4.9.ebuild
new file mode 100644
index 000000000000..5d76249812e6
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-4.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://gitlab.com/mike01/pypacker"
+SRC_URI="${HOMEPAGE}/-/archive/v${PV}/pypacker-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${EPYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}