summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2021-03-18 23:22:31 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-22 15:33:55 +0200
commit3285b2b29823896dd52a131611366897c4220825 (patch)
treec2e1d45bf4bc2affcf6ae9fe72ff6a5965fb804e /net-analyzer/python-gvm
parentnet-analyzer/greenbone-security-assistant: version bump to 20.8.1 (diff)
downloadgentoo-3285b2b29823896dd52a131611366897c4220825.tar.gz
gentoo-3285b2b29823896dd52a131611366897c4220825.tar.bz2
gentoo-3285b2b29823896dd52a131611366897c4220825.zip
net-analyzer/python-gvm: version bump to 21.1.3
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/python-gvm')
-rw-r--r--net-analyzer/python-gvm/Manifest1
-rw-r--r--net-analyzer/python-gvm/python-gvm-21.1.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/Manifest b/net-analyzer/python-gvm/Manifest
index e9e4ba9eb0a2..d25cb1d6a4f0 100644
--- a/net-analyzer/python-gvm/Manifest
+++ b/net-analyzer/python-gvm/Manifest
@@ -2,3 +2,4 @@ DIST python-gvm-1.1.0.tar.gz 160289 BLAKE2B 64dbf79f6749c50cddc2b908c45c6aea6c37
DIST python-gvm-1.2.0.tar.gz 160700 BLAKE2B 40ef2d6e01dee7a93796c5d2f29db06e2a533860f7c612000ad5250d9b291ce90164e3a7c65c77f7131fc12c4622094b22da4eeb989293ad1b33e2754063ec76 SHA512 3eacec521bbd4cbfaec08d1ccabfe1c97898288b8b56779f9e3ceb734f52d78b93faf92674c1eefc555501e0bfdb16ed26316e87c697bbdc5a673d1be2170c00
DIST python-gvm-1.5.0.tar.gz 171471 BLAKE2B 57fa3cc8dfa74a16c56fb4fee0f2c47ede441892a19865271e8c034cb853751f38b3f90cbca6d538d8e59866cd45d0fd8e783a62719c523c6fc9723f4c183a79 SHA512 7c1717dd8f724566232cca50997494012d0364975151afcca8aa483f9fd85d47343f1a2af0124cb762e16d42a057b06d8f8a5e637280e14541a270b14be188e1
DIST python-gvm-1.6.0.tar.gz 175162 BLAKE2B 2c2f9d96911533734807b1aa3e6a56c758122755284a4808ac4e7f974847a12ac8d148e1c8604307965422f311231d721cbbaf09207e85d4425afc5d9534b2e5 SHA512 135ae95d6b5d5226a5ed3e4a7c14e03831005e745039bca86d532cb852a41a973ea1559b1c17b6564787f9448e20c932445dfec0ec8ecf1b39366edc205ea934
+DIST python-gvm-21.1.3.tar.gz 244785 BLAKE2B 7f0a63651a01a914359ea683cf52fe2e1ced22aba0bb90d232c4e5a13f25bb0a9d76a647c2bbe34f0be9615c0ce4d7fb938eee3fbe3a2389b7483b4d55069fee SHA512 eb92be77e69303e0ece54efb5bceaefb469ab1c3f4a2714ec1c839d43584e5760618c39a133aaaeb436c9f62d6deec8f40608e792f408e8cae7c083db857183f
diff --git a/net-analyzer/python-gvm/python-gvm-21.1.3.ebuild b/net-analyzer/python-gvm/python-gvm-21.1.3.ebuild
new file mode 100644
index 000000000000..21cee4b94358
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-21.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/python-gvm/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest