summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-05 16:48:22 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-05 16:48:44 +0100
commitcabf71ef6b3ee16a778958bf50ea68cda59a2be6 (patch)
treeac07a4359d58cf2bf327ecafd90d2867b3f757dd /net-analyzer/rrdtool
parentdev-ruby/rrdtool-bindings: Version 1.7.1 (diff)
downloadgentoo-cabf71ef6b3ee16a778958bf50ea68cda59a2be6.tar.gz
gentoo-cabf71ef6b3ee16a778958bf50ea68cda59a2be6.tar.bz2
gentoo-cabf71ef6b3ee16a778958bf50ea68cda59a2be6.zip
net-analyzer/rrdtool: Version 1.7.1
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/Manifest1
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.7.1-configure.ac.patch12
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.7.1.ebuild189
3 files changed, 202 insertions, 0 deletions
diff --git a/net-analyzer/rrdtool/Manifest b/net-analyzer/rrdtool/Manifest
index 7941d2a78d63..dba3e45fce35 100644
--- a/net-analyzer/rrdtool/Manifest
+++ b/net-analyzer/rrdtool/Manifest
@@ -1,2 +1,3 @@
DIST rrdtool-1.6.0.tar.gz 2186538 BLAKE2B b56ef79b9d45a65cacd7c1d8da2158dcaaff3ebc2ffc0640081cdc2fa3ac643be1ce48a2cac60427a836dc3e457ddb042c95533d0ffbcdefa2978f5659150391 SHA512 45a8f16a2bda9d497c5f39de80236adb7a5bd054a14755c4d130f21cd6430bd0a76caef9632994be56fd1ea2364eb218687ea8ebf945a71ca411221c248f3ebd
DIST rrdtool-1.7.0.tar.gz 2849994 BLAKE2B f7a91fa661728850af55356a69b61ea1d4343c79579823e025e0a0757d1dab0d2cda6387197ece20e07f33a657743350cadfaf6504500f13be472d18e8826a3f SHA512 36d979561601135d74622eaf183701de15cba5e25118f7a308926a695ba84ecb33c3d16511bf4bc80cff055853e2eb85065bc4ed8aef19fc0277c6430ecd319f
+DIST rrdtool-1.7.1.tar.gz 2881346 BLAKE2B e538c6ba3fb6726f0515ed655aa8d5e184f6d3066bb32e981b3254e41c53e29529698da5ef73f8365391180c76d15808d1d727a0834b8025893b01c3b9af8f46 SHA512 ee5c9ff234493442ccd9bfc7031700483011de3e05c01e026509b699cb0d7d3e286e2046357c5fff5807f3e709043c8f218b48b43f8b126a23e228a3927d7b14
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.7.1-configure.ac.patch b/net-analyzer/rrdtool/files/rrdtool-1.7.1-configure.ac.patch
new file mode 100644
index 000000000000..1b65f959c95d
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.7.1-configure.ac.patch
@@ -0,0 +1,12 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -241,9 +241,6 @@
+
+
+
+-dnl add pic flag in any case this makes sure all our code is relocatable
+-dnl eval `./libtool --config | grep pic_flag=`
+-dnl CFLAGS="$CFLAGS $pic_flag"
+
+
+ dnl Checks for library functions.
diff --git a/net-analyzer/rrdtool/rrdtool-1.7.1.ebuild b/net-analyzer/rrdtool/rrdtool-1.7.1.ebuild
new file mode 100644
index 000000000000..41552b5c687b
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.7.1.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=true
+DISTUTILS_SINGLE_IMPL=true
+GENTOO_DEPEND_ON_PERL=no
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit autotools perl-module distutils-r1 flag-o-matic multilib
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
+SRC_URI="${HOMEPAGE}pub/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/8.0.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="dbi doc graph lua perl python rados rrdcgi ruby static-libs tcl tcpd"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="
+ >=dev-libs/glib-2.28.7:2[static-libs(+)?]
+ >=dev-libs/libxml2-2.7.8:2[static-libs(+)?]
+ dbi? ( dev-db/libdbi[static-libs(+)?] )
+ graph? (
+ >=media-libs/libpng-1.5.10:0=[static-libs(+)?]
+ >=x11-libs/cairo-1.10.2[svg,static-libs(+)?]
+ >=x11-libs/pango-1.28
+ )
+ lua? ( dev-lang/lua:*[deprecated] )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ rados? ( sys-cluster/ceph )
+ tcl? ( dev-lang/tcl:0= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+
+DEPEND="
+ ${CDEPEND}
+ sys-apps/groff
+ virtual/pkgconfig
+ virtual/awk
+"
+RDEPEND="
+ ${CDEPEND}
+"
+PDEPEND="
+ ruby? ( ~dev-ruby/rrdtool-bindings-${PV} )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.9-disable-rrd_graph-perl.patch
+ "${FILESDIR}"/${PN}-1.7.0-disable-rrd_graph-cgi.patch
+ "${FILESDIR}"/${PN}-1.7.1-configure.ac.patch
+
+)
+S=${WORKDIR}/${MY_P}
+
+python_compile() {
+ cd bindings/python || die
+ distutils-r1_python_compile
+}
+
+python_install() {
+ cd bindings/python || die
+ distutils-r1_python_install
+}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # At the next version bump, please see if you actually still need this
+ # before adding versions
+ if ! [ -f doc/rrdrados.pod ]; then
+ cp "${FILESDIR}"/${PN}-1.5.5-rrdrados.pod doc/rrdrados.pod
+ else
+ die "File already exists: doc/rrdrados.pod. Remove this code!"
+ fi
+
+ # bug 456810
+ # no time to sleep
+ sed -i \
+ -e 's|$LUA_CFLAGS|IGNORE_THIS_BAD_TEST|g' \
+ -e 's|^sleep 1$||g' \
+ -e '/^dnl.*png/s|^dnl||g' \
+ configure.ac || die
+
+ # Python bindings are built/installed manually
+ sed -i \
+ -e '/^all-local:/s| @COMP_PYTHON@||' \
+ bindings/Makefile.am || die
+
+ if ! use graph; then
+ sed -i \
+ -e '2s:rpn1::; 2s:rpn2::; 6s:create-with-source-4::;' \
+ -e '7s:xport1::; 7s:dcounter1::; 7s:vformatter1::' \
+ tests/Makefile.am || die
+ fi
+
+ echo ${PV/_rc*/} >> VERSION || die
+
+ export rd_cv_gcc_flag__Werror=no
+
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
+
+ # to solve bug #260380
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
+
+ # Stub configure.ac
+ local myconf=()
+ if ! use tcpd; then
+ myconf+=( "--disable-libwrap" )
+ fi
+ if ! use dbi; then
+ myconf+=( "--disable-libdbi" )
+ fi
+ if ! use rados; then
+ myconf+=( "--disable-librados" )
+ fi
+
+ econf \
+ $(use_enable graph rrd_graph) \
+ $(use_enable lua lua-site-install) \
+ $(use_enable lua) \
+ $(use_enable perl perl-site-install) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable rrdcgi) \
+ $(use_enable static-libs static) \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
+ --with-perl-options=INSTALLDIRS=vendor \
+ --disable-ruby-site-install \
+ --disable-ruby \
+ ${myconf[@]}
+}
+
+src_compile() {
+ default
+
+ use python && distutils-r1_src_compile
+}
+
+src_test() {
+ export LC_ALL=C
+ default
+}
+
+src_install() {
+ default
+
+ if ! use doc ; then
+ rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
+ fi
+
+ if use !rrdcgi ; then
+ # uses rrdcgi, causes invalid shebang error in Prefix, useless
+ # without rrdcgi installed
+ rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
+ fi
+
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+
+ dodoc CHANGES CONTRIBUTORS NEWS THREADS TODO
+
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+
+ keepdir /var/lib/rrdcached/journal/
+ keepdir /var/lib/rrdcached/db/
+
+ newconfd "${FILESDIR}"/rrdcached.confd rrdcached
+ newinitd "${FILESDIR}"/rrdcached.init rrdcached
+
+ use python && distutils-r1_src_install
+}