summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:54 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:45:33 +0100
commit3762423b0fbaeeb786329b7618e1344f4b96cf8d (patch)
tree0f6c6ff45f0235fe7169cfd93f8ecd60940a6a0c /net-analyzer/scapy/scapy-2.3.2-r1.ebuild
parentmedia-video/videotrans: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-3762423b0fbaeeb786329b7618e1344f4b96cf8d.tar.gz
gentoo-3762423b0fbaeeb786329b7618e1344f4b96cf8d.tar.bz2
gentoo-3762423b0fbaeeb786329b7618e1344f4b96cf8d.zip
net-analyzer/scapy: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'net-analyzer/scapy/scapy-2.3.2-r1.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-2.3.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-2.3.2-r1.ebuild b/net-analyzer/scapy/scapy-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..179f5908d5da
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.3.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gnuplot pyx crypt graphviz imagemagick visual tcpreplay"
+
+RDEPEND="
+ net-analyzer/tcpdump
+ gnuplot? ( dev-python/gnuplot-py[${PYTHON_USEDEP}] )
+ pyx? ( dev-python/pyx[${PYTHON_USEDEP}] )
+ crypt? ( dev-python/pycrypto[${PYTHON_USEDEP}] )
+ graphviz? ( media-gfx/graphviz )
+ imagemagick? ( virtual/imagemagick-tools )
+ visual? ( dev-python/visual )
+ tcpreplay? ( net-analyzer/tcpreplay )
+"