summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-17 11:53:06 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-17 11:55:33 +0100
commit3ed4bfb11a9fa7cf1bba3746eb75f1f2724ec45f (patch)
treef7be600e9e7cf8829c8be9116b27b9cc11399059 /net-analyzer/scapy/scapy-2.3.2-r1.ebuild
parentdev-libs/libfilezilla: Bump to version 0.20.0 (diff)
downloadgentoo-3ed4bfb11a9fa7cf1bba3746eb75f1f2724ec45f.tar.gz
gentoo-3ed4bfb11a9fa7cf1bba3746eb75f1f2724ec45f.tar.bz2
gentoo-3ed4bfb11a9fa7cf1bba3746eb75f1f2724ec45f.zip
net-analyzer/scapy: Revert "Remove old for gnuplot-py cleanup"
Reverts: b29ebf2ae1f4a697e1861f5ed28b88c7e9744c30 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-analyzer/scapy/scapy-2.3.2-r1.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-2.3.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-2.3.2-r1.ebuild b/net-analyzer/scapy/scapy-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..e3f662d3328b
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.3.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gnuplot pyx crypt graphviz imagemagick tcpreplay"
+
+RDEPEND="
+ net-analyzer/tcpdump
+ gnuplot? ( dev-python/gnuplot-py[${PYTHON_USEDEP}] )
+ pyx? ( dev-python/pyx[${PYTHON_USEDEP}] )
+ crypt? ( || ( dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}] ) )
+ graphviz? ( media-gfx/graphviz )
+ imagemagick? ( virtual/imagemagick-tools )
+ tcpreplay? ( net-analyzer/tcpreplay )
+"