summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-09 23:52:19 +0000
committerSam James <sam@gentoo.org>2021-05-09 23:53:16 +0000
commitbe5688bbcfe8eb7b6ac06192dda990067aa5bcae (patch)
tree5c4f8c4d882328f675e46d870c6924d047c621db /net-analyzer/scapy/scapy-2.4.5.ebuild
parentsys-devel/binutils-config: Stabilize 5.4 arm, #785391 (diff)
downloadgentoo-be5688bbcfe8eb7b6ac06192dda990067aa5bcae.tar.gz
gentoo-be5688bbcfe8eb7b6ac06192dda990067aa5bcae.tar.bz2
gentoo-be5688bbcfe8eb7b6ac06192dda990067aa5bcae.zip
net-analyzer/scapy: add 2.4.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/scapy/scapy-2.4.5.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-2.4.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-2.4.5.ebuild b/net-analyzer/scapy/scapy-2.4.5.ebuild
new file mode 100644
index 000000000000..2c8170223ff8
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/ipython
+ dev-python/matplotlib
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpdump
+ net-analyzer/tcpreplay
+ net-libs/libpcap
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ if ! [[ -f ${PN}/VERSION ]]; then
+ echo ${PV} > ${PN}/VERSION || die
+ else
+ die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}