summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/scli/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/scli/files')
-rw-r--r--net-analyzer/scli/files/scli-0.4.0-configure.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/scli/files/scli-0.4.0-configure.patch b/net-analyzer/scli/files/scli-0.4.0-configure.patch
new file mode 100644
index 000000000000..d942da0adcc5
--- /dev/null
+++ b/net-analyzer/scli/files/scli-0.4.0-configure.patch
@@ -0,0 +1,44 @@
+--- a/configure.in
++++ b/configure.in
+@@ -20,6 +20,8 @@
+ AC_CHECK_PROG(SMIDUMP, smidump, smidump)
+ AC_SUBST(SMIDUMP)
+
++PKG_PROG_PKG_CONFIG
++
+ AC_DEFINE_UNQUOTED(SCLI_PLUGIN_PATH, "${pkglibdir}")
+
+ AC_MSG_CHECKING([whether to enable -Wall])
+@@ -33,19 +35,24 @@
+
+ dnl Checks for libraries.
+
+-AM_PATH_GLIB_2_0(2.0.0, [], AC_MSG_ERROR(scli needs GLIB), gmodule)
+-AM_PATH_GNET_2_0(2.0.0, [], AC_MSG_ERROR(scli needs GNET))
++PKG_CHECK_MODULES(GLIB, glib-2.0 gmodule-2.0 gthread-2.0,[
++ LIBS="$LIBS $GLIB_LIBS"
++ CPPFLAGS="$CPPFLAGS $GLIB_CFLAGS"
++ ], AC_MSG_ERROR(scli needs GLIB))
++PKG_CHECK_MODULES(GNET, gnet-2.0 >= 2.0.0,[
++ LIBS="$LIBS $GNET_LIBS"
++ CPPFLAGS="$CPPFLAGS $GNET_CFLAGS"
++ ], AC_MSG_ERROR(scli needs GNET))
+ dnl AM_PATH_GLIB(1.2.0, [], AC_MSG_ERROR(scli needs GLIB), gmodule)
+ dnl AM_PATH_GTK(1.2.0, [], AC_MSG_ERROR(scli needs GTK))
+-AM_PATH_XML2(2.0.0, [], AC_MSG_ERROR(scli needs libxml2))
++PKG_CHECK_MODULES(XML2, libxml-2.0 >= 2.0.0,[
++ LIBS="$LIBS $XML2_LIBS"
++ CPPFLAGS="$CPPFLAGS $XML2_CFLAGS"
++ ], AC_MSG_ERROR(scli needs libxml2))
+ PKG_CHECK_MODULES(GSNMP, gsnmp, have_gsnmp=true, have_gsnmp=false)
+ AC_SUBST(GSNMP_CFLAGS)
+ AC_SUBST(GSNMP_LIBS)
+-AC_CHECK_LIB(ncurses, initscr, [],
+- AC_CHECK_LIB(curses, initscr, [],
+- AC_MSG_ERROR([scli requires curses functions; install curses first])
+- )
+-)
++PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",AC_MSG_ERROR([ncurses is required]))
+ AC_CHECK_LIB(readline, readline, [],
+ AC_MSG_ERROR([scli requires readline functions; install libreadline first])
+ )