summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/sguil-server/sguil-server-0.8.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/sguil-server/sguil-server-0.8.0.ebuild')
-rw-r--r--net-analyzer/sguil-server/sguil-server-0.8.0.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/net-analyzer/sguil-server/sguil-server-0.8.0.ebuild b/net-analyzer/sguil-server/sguil-server-0.8.0.ebuild
new file mode 100644
index 000000000000..eb91bfcda80a
--- /dev/null
+++ b/net-analyzer/sguil-server/sguil-server-0.8.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib ssl-cert user
+
+MY_PV="${PV/_p/p}"
+DESCRIPTION="Daemon for Sguil Network Security Monitoring"
+HOMEPAGE="http://sguil.sourceforge.net"
+SRC_URI="mirror://sourceforge/sguil/sguil-server-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2 QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND="
+ >=dev-lang/tcl-8.3:0=[-threads]
+ >=dev-tcltk/tclx-8.3
+ dev-tcltk/tcllib
+ dev-tcltk/mysqltcl
+ ssl? ( >=dev-tcltk/tls-1.4.1 )"
+RDEPEND="${DEPEND}
+ net-analyzer/p0f
+ net-analyzer/tcpflow
+ net-misc/openssh"
+
+S="${WORKDIR}/sguil-${MY_PV}"
+
+pkg_setup() {
+ enewgroup sguil
+ enewuser sguil -1 -1 /var/lib/sguil sguil
+}
+
+src_prepare(){
+ sed -i \
+ -e 's:DEBUG 2:DEBUG 1:' -e 's:DAEMON 0:DAEMON 1:' \
+ -e 's:SGUILD_LIB_PATH ./lib:SGUILD_LIB_PATH /usr/lib/sguild:g' \
+ -e 's:/sguild_data/rules:/var/lib/sguil/rules:g' \
+ -e 's:/sguild_data/archive:/var/lib/sguil/archive:g' \
+ -e 's:/usr/lib/sguild:/usr/'$(get_libdir)'/sguild:g' \
+ server/sguild.conf || die
+}
+
+src_install(){
+ dodoc server/sql_scripts/*
+ dodoc doc/CHANGES doc/OPENSSL.README doc/USAGE doc/INSTALL \
+ doc/TODO doc/sguildb.dia
+
+ insopts -m640
+ insinto /etc/sguil
+ doins server/{sguild.email,sguild.users,sguild.conf,sguild.queries,sguild.access,autocat.conf}
+
+ insinto /usr/$(get_libdir)/sguild
+ doins server/lib/*
+ dobin server/sguild
+ newinitd "${FILESDIR}/sguild.initd" sguild
+ newconfd "${FILESDIR}/sguild.confd" sguild
+
+ if use ssl; then
+ sed -i -e "s/#OPENSSL/OPENSSL/" "${D}/etc/conf.d/sguild"
+ fi
+
+ diropts -g sguil -o sguil
+ keepdir \
+ /var/lib/sguil \
+ /var/lib/sguil/archive \
+ /var/lib/sguil/rules
+
+}
+
+pkg_postinst(){
+ if use ssl && ! [ -f "${ROOT}"/etc/sguil/sguild.key ]; then
+ install_cert /etc/sguil/sguild
+ fi
+
+ chown -R sguil:sguil "${ROOT}"/etc/sguil/sguild.*
+ chown -R sguil:sguil "${ROOT}"/usr/lib/sguild
+
+ if [ -d "${ROOT}"/etc/snort/rules ] ; then
+ ln -s /etc/snort/rules "${ROOT}"/var/lib/sguil/rules/${HOSTNAME}
+ fi
+
+ elog
+ elog "Please customize the sguild configuration files in /etc/sguild before"
+ elog "trying to run the daemon. Additionally you will need to setup the"
+ elog "mysql database. See /usr/share/doc/${PF}/INSTALL.gz for information."
+ elog "Please note that it is STRONGLY recommended to mount a separate"
+ elog "filesystem at /var/lib/sguil for both space and performance reasons"
+ elog "as a large amount of data will be kept in the directory structure"
+ elog "underneath that top directory."
+ elog
+ elog "You should create the sguild db as per the install instructions in"
+ elog "/usr/share/doc/${PF}/ and use the appropriate"
+ elog "database setup script located in the same directory."
+
+ elog
+}