summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 00:13:44 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:56 +0100
commit86eeaf50ea081474269d03340ab40faf3d4830ca (patch)
treee7f054ff969343827c76cf50082ea66ed2533246 /net-analyzer/smokeping/smokeping-2.7.3-r1.ebuild
parentnet-analyzer/prelude-lml: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-86eeaf50ea081474269d03340ab40faf3d4830ca.tar.gz
gentoo-86eeaf50ea081474269d03340ab40faf3d4830ca.tar.bz2
gentoo-86eeaf50ea081474269d03340ab40faf3d4830ca.zip
net-analyzer/smokeping: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/smokeping/smokeping-2.7.3-r1.ebuild')
-rw-r--r--net-analyzer/smokeping/smokeping-2.7.3-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-analyzer/smokeping/smokeping-2.7.3-r1.ebuild b/net-analyzer/smokeping/smokeping-2.7.3-r1.ebuild
index 497f430571fb..26e3c02ce8a7 100644
--- a/net-analyzer/smokeping/smokeping-2.7.3-r1.ebuild
+++ b/net-analyzer/smokeping/smokeping-2.7.3-r1.ebuild
@@ -137,3 +137,7 @@ src_install() {
fperms 775 /var/lib/${PN} /var/lib/${PN}/.simg
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}