summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-10-24 10:00:01 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-10-24 10:02:15 -0500
commitf27c272aa3eec5c89fc1966d9ce96db7f32f5e41 (patch)
treed97c572e746420ec914f2fa3632495ff4b73b3c5 /net-analyzer/sshping
parentdev-perl/Exporter-Lite: EAPI=8 bump (diff)
downloadgentoo-f27c272aa3eec5c89fc1966d9ce96db7f32f5e41.tar.gz
gentoo-f27c272aa3eec5c89fc1966d9ce96db7f32f5e41.tar.bz2
gentoo-f27c272aa3eec5c89fc1966d9ce96db7f32f5e41.zip
net-analyzer/sshping: initial import
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-analyzer/sshping')
-rw-r--r--net-analyzer/sshping/Manifest1
-rw-r--r--net-analyzer/sshping/files/sshping-0.1.4-fix-man-dir.patch13
-rw-r--r--net-analyzer/sshping/metadata.xml11
-rw-r--r--net-analyzer/sshping/sshping-0.1.4.ebuild28
4 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/sshping/Manifest b/net-analyzer/sshping/Manifest
new file mode 100644
index 000000000000..5ff59abc1d9a
--- /dev/null
+++ b/net-analyzer/sshping/Manifest
@@ -0,0 +1 @@
+DIST sshping-0.1.4.tar.gz 3536227 BLAKE2B 30ee41324046d5ba5fb38a28acbf11dabadcbe41c506f7e4f51f2a5e95c015251d77ad16c534160eb1b83a871a5d25083b2481a5df91f5beb104279268838ae7 SHA512 16d72099b468c58d44835822a372f97863ba0b73282e8e64c20b0a0e6465e6f9efa634a85b0c7c13d03c470c547b08332820bf177f5bad59984270801ab74782
diff --git a/net-analyzer/sshping/files/sshping-0.1.4-fix-man-dir.patch b/net-analyzer/sshping/files/sshping-0.1.4-fix-man-dir.patch
new file mode 100644
index 000000000000..2758e84b70e4
--- /dev/null
+++ b/net-analyzer/sshping/files/sshping-0.1.4-fix-man-dir.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2e59dd5..d20c9a9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -34,7 +34,7 @@ if (UNIX)
+ endif (UNIX)
+
+ add_custom_target(man ALL DEPENDS ${MAN_TGT})
+-install(FILES ${MAN_TGT} DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man8)
++install(FILES ${MAN_TGT} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man8)
+
+ # Packaging for RPM or DEB
+ find_program(rpmbuild_path "rpmbuild" FALSE)
diff --git a/net-analyzer/sshping/metadata.xml b/net-analyzer/sshping/metadata.xml
new file mode 100644
index 000000000000..14f29f027080
--- /dev/null
+++ b/net-analyzer/sshping/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jchelmert3@posteo.net</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">spook/sshping</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/sshping/sshping-0.1.4.ebuild b/net-analyzer/sshping/sshping-0.1.4.ebuild
new file mode 100644
index 000000000000..86789a0acf0d
--- /dev/null
+++ b/net-analyzer/sshping/sshping-0.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ssh-based ping: measure character echo latency and bandwidth"
+HOMEPAGE="https://github.com/spook/sshping"
+SRC_URI="https://github.com/spook/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-lang/perl"
+DEPEND="net-libs/libssh:="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-man-dir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+
+ cmake_src_configure
+}