summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ssldump/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ssldump/files')
-rw-r--r--net-analyzer/ssldump/files/ssldump-0.9-DLT_LINUX_SLL.patch13
-rw-r--r--net-analyzer/ssldump/files/ssldump-0.9-configure-dylib.patch28
-rw-r--r--net-analyzer/ssldump/files/ssldump-0.9-declaration.patch11
-rw-r--r--net-analyzer/ssldump/files/ssldump-0.9-includes.patch30
-rw-r--r--net-analyzer/ssldump/files/ssldump-0.9-libpcap-header.patch10
-rw-r--r--net-analyzer/ssldump/files/ssldump-0.9-openssl-0.9.8.compile-fix.patch18
-rw-r--r--net-analyzer/ssldump/files/ssldump-0.9-prefix-fix.patch22
7 files changed, 132 insertions, 0 deletions
diff --git a/net-analyzer/ssldump/files/ssldump-0.9-DLT_LINUX_SLL.patch b/net-analyzer/ssldump/files/ssldump-0.9-DLT_LINUX_SLL.patch
new file mode 100644
index 000000000000..9a58c6369929
--- /dev/null
+++ b/net-analyzer/ssldump/files/ssldump-0.9-DLT_LINUX_SLL.patch
@@ -0,0 +1,13 @@
+--- a/base/pcap-snoop.c
++++ b/base/pcap-snoop.c
+@@ -157,6 +157,10 @@
+ return;
+
+ break;
++ case DLT_LINUX_SLL:
++ data+=16;
++ len-=16;
++ break;
+ }
+ network_process_packet(n,&hdr->ts,data,len);
+ }
diff --git a/net-analyzer/ssldump/files/ssldump-0.9-configure-dylib.patch b/net-analyzer/ssldump/files/ssldump-0.9-configure-dylib.patch
new file mode 100644
index 000000000000..941350e8c789
--- /dev/null
+++ b/net-analyzer/ssldump/files/ssldump-0.9-configure-dylib.patch
@@ -0,0 +1,28 @@
+--- a/configure.in
++++ b/configure.in
+@@ -102,14 +102,13 @@
+ AC_MSG_CHECKING(for PCAP library)
+ ac_found_pcap_lib_dir="no"
+ for dir in $ac_pcap_lib_dir; do
+- if test -f $dir/libpcap.a; then
++ if test -f $dir/libpcap.so -o -f $dir/libpcap.dylib; then
+ dnl Ok, we think we've found them, but check that they
+- dnl actually ontain the right functions
++ dnl actually contain the right functions
+ save_LIBS=$LIBS
+- save_LDFLAGS=$LDFLAGS
+ LIBS="-lpcap $LIBS"
+ if test "$dir" != "/usr/lib"; then
+- LDFLAGS="-L$dir $LDFLAGS"
++ LIBS="-L$dir $LIBS"
+ fi
+ AC_TRY_LINK_FUNC(pcap_open_live,ac_linked_libpcap="true",
+ ac_linked_libpcap="false");
+@@ -118,7 +117,6 @@
+ break
+ fi
+ LIBS=$save_LIBS
+- LDFLAGS=$save_LDFLAGS
+ fi
+ done
+
diff --git a/net-analyzer/ssldump/files/ssldump-0.9-declaration.patch b/net-analyzer/ssldump/files/ssldump-0.9-declaration.patch
new file mode 100644
index 000000000000..836b52c84ab2
--- /dev/null
+++ b/net-analyzer/ssldump/files/ssldump-0.9-declaration.patch
@@ -0,0 +1,11 @@
+--- a/ssl/ssl_rec.h
++++ b/ssl/ssl_rec.h
+@@ -54,6 +54,8 @@
+ SSL_CipherSuite *cs,UCHAR *mk,UCHAR *sk,UCHAR *iv));
+ int ssl_decode_rec_data PROTO_LIST((ssl_obj *ssl,ssl_rec_decoder *d,
+ int ct,int version,UCHAR *in,int inl,UCHAR *out,int *outl));
++int ssl3_check_mac(ssl_rec_decoder *d, int ct, int ver, UCHAR *data,
++ UINT4 datalen, UCHAR *mac);
+
+ #endif
+
diff --git a/net-analyzer/ssldump/files/ssldump-0.9-includes.patch b/net-analyzer/ssldump/files/ssldump-0.9-includes.patch
new file mode 100644
index 000000000000..8ca06dcef449
--- /dev/null
+++ b/net-analyzer/ssldump/files/ssldump-0.9-includes.patch
@@ -0,0 +1,30 @@
+--- a/common/lib/r_assoc.c
++++ b/common/lib/r_assoc.c
+@@ -57,6 +57,7 @@
+ static char *RCSSTRING="$Id$";
+
+ #include <r_common.h>
++#include <string.h> /* memcpy() memcmp() */
+ #include "r_assoc.h"
+
+ typedef struct r_assoc_el_ {
+--- a/common/lib/r_bitfield.c
++++ b/common/lib/r_bitfield.c
+@@ -11,6 +11,7 @@
+ static char *RCSSTRING="$Id$";
+
+ #include <r_common.h>
++#include <string.h> /* memcpy() memset() */
+ #include "r_bitfield.h"
+
+ int r_bitfield_create(setp,size)
+--- a/common/lib/r_data.c
++++ b/common/lib/r_data.c
+@@ -47,6 +47,7 @@
+ static char *RCSSTRING="$Id$";
+
+ #include <r_common.h>
++#include <string.h> /* memcmp() memcpy() memset() */
+ #include <r_data.h>
+
+ int r_data_create(dp,d,l)
diff --git a/net-analyzer/ssldump/files/ssldump-0.9-libpcap-header.patch b/net-analyzer/ssldump/files/ssldump-0.9-libpcap-header.patch
new file mode 100644
index 000000000000..a9a724658ccf
--- /dev/null
+++ b/net-analyzer/ssldump/files/ssldump-0.9-libpcap-header.patch
@@ -0,0 +1,10 @@
+--- a/base/pcap-snoop.c
++++ b/base/pcap-snoop.c
+@@ -49,7 +49,6 @@
+
+ #include <pcap.h>
+ #include <unistd.h>
+-#include <net/bpf.h>
+ #ifndef _WIN32
+ #include <sys/param.h>
+ #endif
diff --git a/net-analyzer/ssldump/files/ssldump-0.9-openssl-0.9.8.compile-fix.patch b/net-analyzer/ssldump/files/ssldump-0.9-openssl-0.9.8.compile-fix.patch
new file mode 100644
index 000000000000..2ce16d54f168
--- /dev/null
+++ b/net-analyzer/ssldump/files/ssldump-0.9-openssl-0.9.8.compile-fix.patch
@@ -0,0 +1,18 @@
+--- a/ssl/ssldecode.c
++++ b/ssl/ssldecode.c
+@@ -51,6 +51,7 @@
+ #include <openssl/ssl.h>
+ #include <openssl/hmac.h>
+ #include <openssl/evp.h>
++#include <openssl/md5.h>
+ #include <openssl/x509v3.h>
+ #endif
+ #include "ssldecode.h"
+@@ -131,6 +132,7 @@
+ ssl_decode_ctx *d=0;
+ int r,_status;
+
++ SSL_library_init();
+ SSLeay_add_all_algorithms();
+ if(!(d=(ssl_decode_ctx *)malloc(sizeof(ssl_decode_ctx))))
+ ABORT(R_NO_MEMORY);
diff --git a/net-analyzer/ssldump/files/ssldump-0.9-prefix-fix.patch b/net-analyzer/ssldump/files/ssldump-0.9-prefix-fix.patch
new file mode 100644
index 000000000000..74d7ddcd6f68
--- /dev/null
+++ b/net-analyzer/ssldump/files/ssldump-0.9-prefix-fix.patch
@@ -0,0 +1,22 @@
+eliminates unused variable ROOT, which disturbs ld from Prefix. Bug #414335
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -46,13 +46,12 @@ BINDIR=@sbindir@
+ MANDIR=@mandir@
+ RM=rm -f
+
+-ROOT=./
+-ANALYZE_SRCDIR=$(ROOT)base/
++ANALYZE_SRCDIR=base/
+ COMMONDIR=common/
+ COMMON_LIB_SRCDIR=$(COMMONDIR)lib/
+-ANALYZE_NULL_SRCDIR=$(ROOT)null/
+-ANALYZE_SSL_SRCDIR=$(ROOT)ssl/
+-ANALYZE_RECORD_SRCDIR=$(ROOT)@RECORD_MOD@/
++ANALYZE_NULL_SRCDIR=null/
++ANALYZE_SSL_SRCDIR=ssl/
++ANALYZE_RECORD_SRCDIR=@RECORD_MOD@/
+ include rules.mk
+
+ include $(COMMON_LIB_SRCDIR)/targets.mk