summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2017-11-17 12:45:09 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-18 22:00:46 +0100
commit7646dc9903e447c9d6177a13a58f34e626eea8a7 (patch)
tree1a8e3eee82c1471c3395acec6bc3c12b51edbd91 /net-analyzer/sslsplit/sslsplit-9999.ebuild
parentdev-python/pygresql: stable 5.0.4 for ppc, bug #641570 (diff)
downloadgentoo-7646dc9903e447c9d6177a13a58f34e626eea8a7.tar.gz
gentoo-7646dc9903e447c9d6177a13a58f34e626eea8a7.tar.bz2
gentoo-7646dc9903e447c9d6177a13a58f34e626eea8a7.zip
net-analyzer/sslsplit: New ebuild
Introduce a new ebuild for sslsplit, the tool for transparent SSL/TLS interception. Closes: https://bugs.gentoo.org/637926 Closes: https://github.com/gentoo/gentoo/pull/6210
Diffstat (limited to 'net-analyzer/sslsplit/sslsplit-9999.ebuild')
-rw-r--r--net-analyzer/sslsplit/sslsplit-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/sslsplit/sslsplit-9999.ebuild b/net-analyzer/sslsplit/sslsplit-9999.ebuild
new file mode 100644
index 000000000000..76b1b4f09086
--- /dev/null
+++ b/net-analyzer/sslsplit/sslsplit-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Transparent SSL/TLS interception"
+HOMEPAGE="http://www.roe.ch/SSLsplit"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="test"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/droe/${PN}"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/droe/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ elibc_musl? ( sys-libs/fts-standalone )
+ dev-libs/libevent[ssl,threads]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ default
+
+ use elibc_musl && append-libs "-lfts"
+
+ sed -i 's/-D_FORTIFY_SOURCE=2 //g' GNUmakefile || die
+ sed -i 's/\<FEATURES\>/SSLSPLIT_FEATURES/g' GNUmakefile build.c || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc AUTHORS.md NEWS.md README.md
+}