summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-07-17 21:30:28 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-17 22:09:59 +0200
commit2fa67aeb1448e023feb007a4f83003c759013924 (patch)
tree966fe509defabfc182faf3d39c9537279359da36 /net-analyzer/suricata
parentdev-python/ruamel-yaml: support python3_9 and pypy3 (diff)
downloadgentoo-2fa67aeb1448e023feb007a4f83003c759013924.tar.gz
gentoo-2fa67aeb1448e023feb007a4f83003c759013924.tar.bz2
gentoo-2fa67aeb1448e023feb007a4f83003c759013924.zip
net-analyzer/suricata: support python3_9
Builds, tests and installs fine, and at least suricata-update works without problems. Tested pypy3 support as well and it needs work, somehow Python modules for this implementation end up in /usr/site-packages. Tools work fine once the modules have been manually moved to the right directory, though. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-analyzer/suricata')
-rw-r--r--net-analyzer/suricata/suricata-5.0.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-analyzer/suricata/suricata-5.0.3.ebuild b/net-analyzer/suricata/suricata-5.0.3.ebuild
index c1f707b13422..d159cf584dac 100644
--- a/net-analyzer/suricata/suricata-5.0.3.ebuild
+++ b/net-analyzer/suricata/suricata-5.0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit autotools flag-o-matic linux-info python-single-r1 systemd
@@ -65,7 +65,7 @@ pkg_pretend() {
fi
CONFIG_CHECK="~XDP_SOCKETS"
- ERROR_XDP_SOCKETS="CONFIG_XDP_SOCKETS is not set, making it impossible for Suricata will to load XDP programs. "
+ ERROR_XDP_SOCKETS="CONFIG_XDP_SOCKETS is not set, making it impossible for Suricata to load XDP programs. "
ERROR_XDP_SOCKETS+="Other eBPF features should work normally."
check_extra_config
fi