summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-22 04:48:05 +0100
committerSam James <sam@gentoo.org>2022-05-22 04:49:14 +0100
commitda3857c7f51b6e6241d705d1f9c0248d50b6043e (patch)
tree9ce3fe102d56ee52c5e7cd4fe3b4a7b2bfc56a79 /net-analyzer/tcpflow
parentnet-analyzer/pypacker: add 5.1 (diff)
downloadgentoo-da3857c7f51b6e6241d705d1f9c0248d50b6043e.tar.gz
gentoo-da3857c7f51b6e6241d705d1f9c0248d50b6043e.tar.bz2
gentoo-da3857c7f51b6e6241d705d1f9c0248d50b6043e.zip
net-analyzer/tcpflow: update EAPI 7 -> 8; use release tarball; drop Python
- Port EAPI 7 -> EAPI 8 - Use release tarball - Force Bash for now for configure given lots of activity since last release - Drop Python bindings -- were (automagically) linking against Python 2.7! No sign of fixing that upstream, so just forcefully disable them. - Fix Wformat-security issue Closes: https://bugs.gentoo.org/846122 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpflow')
-rw-r--r--net-analyzer/tcpflow/Manifest1
-rw-r--r--net-analyzer/tcpflow/files/tcpflow-1.6.1-wformat-security.patch24
-rw-r--r--net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild56
3 files changed, 81 insertions, 0 deletions
diff --git a/net-analyzer/tcpflow/Manifest b/net-analyzer/tcpflow/Manifest
index 2ca13347df50..1ade1d691c3b 100644
--- a/net-analyzer/tcpflow/Manifest
+++ b/net-analyzer/tcpflow/Manifest
@@ -1,3 +1,4 @@
DIST be13_api-20170924.tar.gz 75724 BLAKE2B a5257346b9c0740d9758543fe7772c960e1941735abefe4d24d347631b35d1511fde8eb5a58dbb2824c54e78ee0d686a2549ceea2c1dc91e05ef92899c8b3c2d SHA512 5bf0d28f23df9436304245ccbdbf4af5b0f65e62b92e3039cfb9a70fe2056aa90dcce906db02f3df83fcf2a415c8a46f0f75468d48e13b15673d11c447a4c9c4
DIST dfxml-20170921.tar.gz 163616 BLAKE2B 17214d15596a136efb2afc7246ee0f5696620b5aac7c2d78e37764f51487ff816de5a7c0f59e7484d358a8cd8eab34841716970cd859f0ce868ac29c8532754c SHA512 0885947aaf8efe639c13324413ef0cca49750027b48b434f226fb9fbfba494e84e245da879dc0d77b46bddc27798f7f5df12590fce47b096683034bbc61280e1
+DIST tcpflow-1.6.1-tag.tar.gz 915245 BLAKE2B 22a1540415d6321d4ba43035f386aaea177e9d3244ff1dcdedcb0c8a72f487a969372b76b85f6acec4f0f1430b51230ceb665466af388d2bfe123a57dcd4224b SHA512 9c0357ca816bf4316ce7a461e5d18c5043a6938828ce83a613a952d5804cc6b701028a666b352da922d69447ab7f5d4c9f66585872e7b116c0f1aebebc38682b
DIST tcpflow-1.6.1.tar.gz 915502 BLAKE2B 6560d11fe6a2b6bd77ddcffb47338e9af358a0f5ec07402ec81dae4cf87dd5cc26bf300df014927df8b8b6143e14553dd2a70cb63769dc4f2525cf9dd1967582 SHA512 ec5b9d5e5f0bc1d6582b9f2537c9ba6c8ae3d9c8f88fb0c67ef031146a515d19caa5ecd365492fb5daf8ddde77b58ea5190290b8e43b40abcdea5aaaef5e2e1c
diff --git a/net-analyzer/tcpflow/files/tcpflow-1.6.1-wformat-security.patch b/net-analyzer/tcpflow/files/tcpflow-1.6.1-wformat-security.patch
new file mode 100644
index 000000000000..092a08dd7664
--- /dev/null
+++ b/net-analyzer/tcpflow/files/tcpflow-1.6.1-wformat-security.patch
@@ -0,0 +1,24 @@
+https://github.com/simsong/tcpflow/issues/238
+https://github.com/simsong/tcpflow/commit/a0697509c4657e2fd94f941e43a2d4c86ddf9fe4
+
+From: "Simson L. Garfinkel" <simsong@acm.org>
+Date: Thu, 11 Mar 2021 19:30:54 -0500
+Subject: [PATCH] Update datalink.cpp (#239)
+
+per https://salsa.debian.org/debian/tcpflow/-/blob/master/debian/patches/fix-werror-format-security.patch
+Closes https://github.com/simsong/tcpflow/issues/238
+--- a/src/datalink.cpp
++++ b/src/datalink.cpp
+@@ -171,10 +171,7 @@ void dl_ethernet(u_char *user, const struct pcap_pkthdr *h, const u_char *p)
+ break;
+ }
+ } catch( std::logic_error e){
+- std::string s(std::string("warning: caught std::logic_error ")
+- + e.what()
+- + std::string(" in packet"));
+- DEBUG(6)(s.c_str());
++ DEBUG(6)("Warning: caught std::logic_error %s in packet",e.what());
+ }
+ }
+
+
diff --git a/net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild b/net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..07306743ad75
--- /dev/null
+++ b/net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A tool for monitoring, capturing and storing TCP connections flows"
+HOMEPAGE="https://github.com/simsong/tcpflow"
+SRC_URI="
+ https://api.github.com/repos/simsong/be13_api/tarball/c81521d768bb78499c069fcd7c47adc8eee0350c -> be13_api-20170924.tar.gz
+ https://api.github.com/repos/simsong/dfxml/tarball/7d11eaa7da8d31f588ce8aecb4b4f5e7e8169ba6 -> dfxml-20170921.tar.gz
+ https://github.com/simsong/tcpflow/archive/refs/tags/${P}.tar.gz -> ${P}-tag.tar.gz
+"
+S="${WORKDIR}"/${PN}-${P}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="cairo test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite
+ dev-libs/boost:=
+ dev-libs/openssl:=
+ net-libs/http-parser:=
+ net-libs/libpcap
+ sys-libs/libcap-ng
+ sys-libs/zlib:=
+ cairo? (
+ x11-libs/cairo
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( sys-apps/coreutils )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0_alpha-libcapng.patch
+ "${FILESDIR}"/${PN}-1.5.2-gentoo.patch
+ "${FILESDIR}"/${PN}-1.6.1-wformat-security.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -fpermissive
+
+ # Disable Python because it's Python 2.7 only, even as of 1.6.1!
+ export ac_cv_header_python2_7_Python_h=no
+ export ac_cv_lib_python2_7_Py_Initialize=no
+
+ CONFIG_SHELL="${BROOT}"/bin/bash econf $(usex cairo --enable-cairo=true --enable-cairo=false)
+}