summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-01 16:36:45 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-01 16:39:39 +0100
commit4344075efcc6c42845677630b08265e05241c05b (patch)
treec6b8c04e44212a3d4f1a987776a18ca157b84ac0 /net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild
parentdev-libs/9libs: amd64 stable wrt bug #704436 (diff)
downloadgentoo-4344075efcc6c42845677630b08265e05241c05b.tar.gz
gentoo-4344075efcc6c42845677630b08265e05241c05b.tar.bz2
gentoo-4344075efcc6c42845677630b08265e05241c05b.zip
net-analyzer/tcpstat: Version 1.5_p8
* Split up -db patch * Apply Debian patches * Fix -L-lpcap * Depend on sys-libs/db:* for tcpprof(1) Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild')
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild b/net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild
new file mode 100644
index 000000000000..fbd6a2b9111c
--- /dev/null
+++ b/net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="Reports network interface statistics"
+HOMEPAGE="https://www.frenchfries.net/paul/tcpstat/"
+SRC_URI="
+ ${HOMEPAGE}${P/_p*}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-$(ver_cut 4).debian.tar.xz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/db:*
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=( AUTHORS ChangeLog NEWS README doc/Tips_and_Tricks.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
+ "${FILESDIR}"/${P}-ipv6.patch
+ "${FILESDIR}"/${P}-libpcap.patch
+ "${FILESDIR}"/${P}-off-by-one.patch
+ "${FILESDIR}"/${P}-unused.patch
+)
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+ eapply $(
+ for patch in $(cat "${WORKDIR}"/debian/patches/series)
+ do echo "${WORKDIR}"/debian/patches/${patch}
+ done
+ ) ${PATCHES[@]}
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -Wall -Wextra
+ econf \
+ $(use_enable ipv6) \
+ --with-pcap-include='' \
+ --with-pcap-lib="$( $(tc-getPKG_CONFIG) --libs libpcap)"
+}
+
+src_install() {
+ default
+ dobin src/{catpcap,packetdump}
+ newdoc src/README README.src
+}