summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-30 11:49:23 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-30 11:49:30 +0200
commit90ef900223244786e7b7a07ce9c47978ba075dd0 (patch)
treede15ac7b0ff00f14e4459ff8dbfadbb14ca561d7 /net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild
parentnet-libs/nodejs: amd64 stable wrt bug #742893 (diff)
downloadgentoo-90ef900223244786e7b7a07ce9c47978ba075dd0.tar.gz
gentoo-90ef900223244786e7b7a07ce9c47978ba075dd0.tar.bz2
gentoo-90ef900223244786e7b7a07ce9c47978ba075dd0.zip
net-analyzer/tcptrace: Version 6.6.7_p6
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild')
-rw-r--r--net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild b/net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild
new file mode 100644
index 000000000000..f08f5f8fd7de
--- /dev/null
+++ b/net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A Tool for analyzing network packet dumps"
+HOMEPAGE="http://www.tcptrace.org/"
+SRC_URI="
+ http://www.tcptrace.org/download/${P/_p*}.tar.gz
+ http://www.tcptrace.org/download/old/6.6/${P/_p*}.tar.gz
+ mirror://debian/pool/main/t/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P/_p*}-cross-compile.patch
+ "${FILESDIR}"/${P/_p*}-_DEFAULT_SOURCE.patch
+)
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+ default
+
+ eapply \
+ $(awk '{ print "'"${WORKDIR}"'/debian/patches/" $0; }' < "${WORKDIR}"/debian/patches/series)
+
+ eautoreconf
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcptrace xpl2gpl
+
+ newman tcptrace.man tcptrace.1
+ dodoc CHANGES COPYRIGHT FAQ README* THANKS WWW
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Note: tcptrace outputs its graphs in the xpl (xplot)"
+ elog "format. Since xplot is unavailable, you will have to"
+ elog "use the included xpl2gpl utility to convert it to"
+ elog "the gnuplot format."
+ fi
+}