summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-14 05:27:23 +0100
committerSam James <sam@gentoo.org>2022-07-14 05:27:23 +0100
commit532cb832d9081b3d808ad159b9684d1ac7a0b8d0 (patch)
tree346ba3b5627e2b4b237b69744f7f74211fef0744 /net-analyzer/termshark
parentdev-util/diffoscope: add 218 (diff)
downloadgentoo-532cb832d9081b3d808ad159b9684d1ac7a0b8d0.tar.gz
gentoo-532cb832d9081b3d808ad159b9684d1ac7a0b8d0.tar.bz2
gentoo-532cb832d9081b3d808ad159b9684d1ac7a0b8d0.zip
net-analyzer/termshark: add 2.4.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/termshark')
-rw-r--r--net-analyzer/termshark/Manifest2
-rw-r--r--net-analyzer/termshark/termshark-2.4.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/termshark/Manifest b/net-analyzer/termshark/Manifest
index fe40fed940d0..adb08055fa39 100644
--- a/net-analyzer/termshark/Manifest
+++ b/net-analyzer/termshark/Manifest
@@ -1,2 +1,4 @@
DIST termshark-2.3.0-deps.tar.xz 142126384 BLAKE2B 3693a5b5470c338a510aa964059e001f3f4d68a3f824191bb7debefa61976e30d10c77ce5e7ef68836732c7a317e2d9a20c170b3a4565b456c130b9b8999a16a SHA512 ccf3576bba18cf429610deea7c69479fae06368d12e584fd9bd0e3d7409069d6994fa3ecc27fe84f38bcc2606018587de1bf28cde103e9477e39351c94dd2c31
DIST termshark-2.3.0.tar.gz 382710 BLAKE2B 7c2953188829d950bc005cc2b9d568ece6fdc636c1bdf2e6d29c03af5358894238aff072848e51e8298e317c6b5467c6e1a6823c1abd5a432c819ca44d5f4f9a SHA512 0ed780ec1ba86d2a6eb11c940f00475c750075d5e1ae4a6022f465572717126df941e933e2db7123d802b721f8e1187014f02d4c5dfd84c1a55009045dce5a88
+DIST termshark-2.4.0-deps.tar.xz 188885928 BLAKE2B d6b16b91e5457902d3762715f53f6fbaefd63342a999fda580863cc3b370d0e6d4c5f213df700c7df3691077026f7a8f06339786bf7bbf816bb2551f43b8d2db SHA512 4b6da25c5e6a2077004b45149a430096e0f3ff8c159cf4bccbf18cf2ea299d9fd7922c97d23d4a86ba7b9c4068c55846e3375bc0517f3cfc6017e5fcfb448371
+DIST termshark-2.4.0.tar.gz 427503 BLAKE2B df232595477d62480ba8ba994e635f01bc5a5ffd09378da37c01847d899e4938a92c8304e26ea425b7a72cfd71f918686a4683e1a04883c3c92e26104b9f84be SHA512 378bb67ff50a8dfa80f614540371f326627e73bdf63bceb183ed73afbbf9dead4e0597fb969ba49c4ee3d3de00ac7bb91166421c19c788df47ff8d9fcbc5b9fc
diff --git a/net-analyzer/termshark/termshark-2.4.0.ebuild b/net-analyzer/termshark/termshark-2.4.0.ebuild
new file mode 100644
index 000000000000..5a3dcf379bba
--- /dev/null
+++ b/net-analyzer/termshark/termshark-2.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A terminal UI for tshark, inspired by Wireshark"
+HOMEPAGE="https://termshark.io/"
+SRC_URI="https://github.com/gcla/termshark/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# termshark doesn't link against wireshark. It reads data via IPC during
+# runtime.
+RDEPEND="
+ net-analyzer/wireshark[dumpcap,pcap,tshark]
+"
+
+src_compile() {
+ ego build ./...
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ GOBIN="${S}/bin" ego install ./...
+
+ dobin bin/${PN}
+ dodoc README.md
+ dodoc docs/*
+}