summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/w3af
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/w3af')
-rw-r--r--net-analyzer/w3af/Manifest2
-rw-r--r--net-analyzer/w3af/files/use_simplejson_instead_of_jsonpy.patch105
-rw-r--r--net-analyzer/w3af/files/w3af_console3
-rw-r--r--net-analyzer/w3af/files/w3af_gui3
-rw-r--r--net-analyzer/w3af/metadata.xml15
-rw-r--r--net-analyzer/w3af/w3af-1.1-r1.ebuild71
-rw-r--r--net-analyzer/w3af/w3af-1.5.ebuild77
7 files changed, 276 insertions, 0 deletions
diff --git a/net-analyzer/w3af/Manifest b/net-analyzer/w3af/Manifest
new file mode 100644
index 000000000000..38be583e095d
--- /dev/null
+++ b/net-analyzer/w3af/Manifest
@@ -0,0 +1,2 @@
+DIST w3af-1.1.tar.bz2 39994121 SHA256 0bf3cec513931b9bf20e6f753dedeaab57b5cad303489ab9ff365786c04d9444 SHA512 9a6c7d474d61f9039c150b44d4c6027451d58e925e47083262105f62b0fca718373103015e3f5bbed1cb89a40c9c057d3d54ce0c533ad3cc90e8ff24e193f868 WHIRLPOOL cb5d0d7bc9096ae27e5597e5dfd2963e03e0b7f4939fb0583ef61d2dec0c8b595ccbfb3e43f4ed170cb8ac79a74f654a5502eeb5d590138f43cfd7cdbe3e4e1f
+DIST w3af-1.5.tar.gz 31147412 SHA256 ce3ac0c5a1c1ae4f8aba012619e400558bf33b77080af61a9756d615883c523f SHA512 5b0b83e36b35883bd78fe990e9e5f0c955e49a22421d8eee4ec877cda842e79c8af0b490f0927ea253bdd60b957fbacf7ad1116e2c3d93023f160691aa50ce7e WHIRLPOOL 79662c1bbf05b825aa5251b43f98ebe118780d456e3dab8368d51c055792c435435cc245ec6d5f897c49a6445e90503d8917a7aa4ef3af6d87c5dcdf3a287b47
diff --git a/net-analyzer/w3af/files/use_simplejson_instead_of_jsonpy.patch b/net-analyzer/w3af/files/use_simplejson_instead_of_jsonpy.patch
new file mode 100644
index 000000000000..306c24a59f8a
--- /dev/null
+++ b/net-analyzer/w3af/files/use_simplejson_instead_of_jsonpy.patch
@@ -0,0 +1,105 @@
+--- ./core/controllers/misc/dependencyCheck.py.old 2010-10-19 09:58:19.000000000 +0200
++++ ./core/controllers/misc/dependencyCheck.py 2010-10-19 09:58:32.000000000 +0200
+@@ -95,15 +95,6 @@
+ except:
+ print 'You have to install pyPdf lib. Debian based distributions: apt-get install python-pypdf'
+ sys.exit( 1 )
+-
+- try:
+- from extlib.jsonpy import json as json
+- except:
+- try:
+- import json
+- except:
+- print 'You have to install python-json lib. Debian based distributions: apt-get install python-json'
+- sys.exit( 1 )
+
+ try:
+ from OpenSSL import SSL
+--- core/data/fuzzer/fuzzer.py.old 2010-10-19 10:00:59.000000000 +0200
++++ core/data/fuzzer/fuzzer.py 2010-10-19 10:02:14.000000000 +0200
+@@ -38,9 +38,9 @@
+ from core.data.dc.cookie import cookie as cookie
+ from core.data.dc.dataContainer import dataContainer as dc
+ try:
+- from extlib.jsonpy import json as json
++ import extlib.simplejson as json
+ except:
+- import json
++ import simplejson as json
+ from core.data.request.httpPostDataRequest import httpPostDataRequest
+ from core.data.request.httpQsRequest import httpQsRequest
+
+@@ -210,7 +210,7 @@
+
+ # Now, fuzz the parsed JSON data...
+ postdata = freq.getData()
+- jsonPostData = json.read( postdata )
++ jsonPostData = json.loads( postdata )
+ return _makeMutants( freq, mutantClass, mutant_str_list, fuzzableParamList , append, jsonPostData )
+
+ def isJSON( freq ):
+@@ -222,7 +222,7 @@
+ # We have something that's not URL encoded in the postdata, it could be something
+ # like JSON, XML, or multipart encoding. Let's try with JSON
+ try:
+- jsonPostData = json.read( postdata )
++ jsonPostData = json.loads( postdata )
+ except:
+ # It's not json, maybe XML or multipart, I don't really care ( at least not in this section of the code )
+ return False
+--- core/data/request/frFactory.py.old 2010-10-19 10:03:50.000000000 +0200
++++ core/data/request/frFactory.py 2010-10-19 10:04:38.000000000 +0200
+@@ -37,9 +37,9 @@
+
+ # for json
+ try:
+- from extlib.jsonpy import json as json
++ import extlib.simplejson as json
+ except:
+- import json
++ import simplejson as json
+
+ from core.controllers.w3afException import w3afException
+ import core.controllers.outputManager as om
+@@ -200,7 +200,7 @@
+ # Case #2, JSON request
+ #
+ try:
+- dc = json.read( postData )
++ dc = json.loads( postData )
+ except:
+ pass
+ else:
+--- core/data/request/jsonPostDataRequest.py.old 2010-10-19 10:12:22.000000000 +0200
++++ core/data/request/jsonPostDataRequest.py 2010-10-19 10:15:05.000000000 +0200
+@@ -25,9 +25,9 @@
+ from core.data.request.httpPostDataRequest import httpPostDataRequest
+ import core.data.dc.dataContainer as dc
+ try:
+- from extlib.jsonpy import json as json
++ import extlib.simplejson as json
+ except:
+- import json
++ import simplejson
+
+ class jsonPostDataRequest(httpPostDataRequest):
+ '''
+@@ -43,7 +43,7 @@
+ '''
+ @return: A string that represents the JSON data saved in the dc.
+ '''
+- res = json.write(self._dc)
++ res = json.dumps(self._dc)
+ return res
+
+ def __str__( self ):
+@@ -54,7 +54,7 @@
+ strRes += self._url
+ strRes += ' | Method: ' + self._method
+ strRes += ' | JSON: ('
+- strRes += json.write(self._dc)
++ strRes += json.dumps(self._dc)
+ strRes += ')'
+ return strRes
+
diff --git a/net-analyzer/w3af/files/w3af_console b/net-analyzer/w3af/files/w3af_console
new file mode 100644
index 000000000000..93212cefb237
--- /dev/null
+++ b/net-analyzer/w3af/files/w3af_console
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/lib/w3af
+./w3af_console $*
diff --git a/net-analyzer/w3af/files/w3af_gui b/net-analyzer/w3af/files/w3af_gui
new file mode 100644
index 000000000000..41f4802e3ae1
--- /dev/null
+++ b/net-analyzer/w3af/files/w3af_gui
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/lib/w3af
+./w3af_gui $*
diff --git a/net-analyzer/w3af/metadata.xml b/net-analyzer/w3af/metadata.xml
new file mode 100644
index 000000000000..ea60feff633f
--- /dev/null
+++ b/net-analyzer/w3af/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>clabbe.montjoie@gmail.com</email>
+ <name>LABBE Corentin (Montjoie)</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">andresriancho/w3af</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/w3af/w3af-1.1-r1.ebuild b/net-analyzer/w3af/w3af-1.1-r1.ebuild
new file mode 100644
index 000000000000..25f30027ca3e
--- /dev/null
+++ b/net-analyzer/w3af/w3af-1.1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit multilib python-single-r1 versionator
+
+MY_P=${PN}-"$(replace_version_separator 2 '-')"
+
+DESCRIPTION="Web Application Attack and Audit Framework"
+HOMEPAGE="http://w3af.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk"
+
+RDEPEND="
+ >=dev-python/fpconst-0.7.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nltk[${PYTHON_USEDEP}]
+ dev-python/pybloomfiltermmap[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyPdf[${PYTHON_USEDEP}]
+ dev-python/python-cluster[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/soappy[${PYTHON_USEDEP}]
+ dev-python/pysvn[${PYTHON_USEDEP}]
+ || (
+ net-analyzer/gnu-netcat
+ net-analyzer/netcat
+ net-analyzer/netcat6
+ )
+ >=net-analyzer/scapy-2
+ gtk? (
+ media-gfx/graphviz
+ >dev-python/pygtk-2.0
+ dev-python/pygtksourceview
+ )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare(){
+ rm -r extlib/{cluster,fpconst-0.7.2,pyPdf,SOAPpy,yaml} || die
+ sed -i 's,extlib.pyPdf.,,' core/data/parsers/pdfParser.py || die
+ rm readme/{GPL,INSTALL} || die
+ rm plugins/attack/payloads/code/netcat || die #bug 349780
+ esvn_clean
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/w3af
+ doins -r core extlib locales plugins profiles scripts tools w3af_gui w3af_console
+ fperms +x /usr/$(get_libdir)/w3af/w3af_{gui,console}
+ dobin "${FILESDIR}"/w3af_console
+ use gtk && dobin "${FILESDIR}"/w3af_gui
+ #use flag doc is here because doc is bigger than 3 Mb
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/
+ doins -r readme/*
+ fi
+ python_fix_shebang "${ED}"usr/$(get_libdir)/${PN}
+}
diff --git a/net-analyzer/w3af/w3af-1.5.ebuild b/net-analyzer/w3af/w3af-1.5.ebuild
new file mode 100644
index 000000000000..ae6158f1434d
--- /dev/null
+++ b/net-analyzer/w3af/w3af-1.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit multilib python-single-r1
+
+DESCRIPTION="Web Application Attack and Audit Framework"
+HOMEPAGE="http://w3af.sourceforge.net/"
+SRC_URI="https://github.com/andresriancho/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc gtk"
+
+#w3af seems to ship sqlmap? maybe we should split this out...
+
+QA_PREBUILT="
+ usr/$(get_libdir)/${PN}/plugins/attack/db/sqlmap/udf/mysql/linux/32/lib_mysqludf_sys.so
+ usr/$(get_libdir)/${PN}/plugins/attack/db/sqlmap/udf/mysql/linux/64/lib_mysqludf_sys.so
+ usr/$(get_libdir)/${PN}/plugins/attack/db/sqlmap/udf/postgresql/linux/*/8.2/lib_postgresqludf_sys.so
+ usr/$(get_libdir)/${PN}/plugins/attack/db/sqlmap/udf/postgresql/linux/*/8.3/lib_postgresqludf_sys.so
+ usr/$(get_libdir)/${PN}/plugins/attack/db/sqlmap/udf/postgresql/linux/*/8.4/lib_postgresqludf_sys.so
+ usr/$(get_libdir)/${PN}/plugins/attack/db/sqlmap/udf/postgresql/linux/*/9.0/lib_postgresqludf_sys.so"
+
+RDEPEND="
+ >=dev-python/fpconst-0.7.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nltk[${PYTHON_USEDEP}]
+ dev-python/pybloomfiltermmap[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyPdf[${PYTHON_USEDEP}]
+ dev-python/python-cluster[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/soappy[${PYTHON_USEDEP}]
+ dev-python/pysvn[${PYTHON_USEDEP}]
+ || (
+ net-analyzer/gnu-netcat
+ net-analyzer/netcat
+ net-analyzer/netcat6
+ )
+ >=net-analyzer/scapy-2
+ gtk? (
+ media-gfx/graphviz
+ >dev-python/pygtk-2.0
+ dev-python/pygtksourceview
+ )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare(){
+ rm doc/{GPL,INSTALL} || die
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ doins -r core locales plugins profiles scripts tools w3af_gui w3af_console
+ fperms +x /usr/$(get_libdir)/${PN}/${PN}_{gui,console}
+ dobin "${FILESDIR}"/${PN}_console
+ if use gtk ; then
+ dobin "${FILESDIR}"/${PN}_gui
+ else
+ rm "${ED}"/usr/$(get_libdir)/${PN}/w3af_gui
+ fi
+ #use flag doc is here because doc is bigger than 3 Mb
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/
+ doins -r doc/*
+ fi
+ python_fix_shebang "${ED}"usr/$(get_libdir)/${PN}
+}