summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /net-analyzer/zabbix/zabbix-3.4.15.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/zabbix/zabbix-3.4.15.ebuild')
-rw-r--r--net-analyzer/zabbix/zabbix-3.4.15.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/net-analyzer/zabbix/zabbix-3.4.15.ebuild b/net-analyzer/zabbix/zabbix-3.4.15.ebuild
index 4d9f2799daa6..0169c3ac73bf 100644
--- a/net-analyzer/zabbix/zabbix-3.4.15.ebuild
+++ b/net-analyzer/zabbix/zabbix-3.4.15.ebuild
@@ -138,13 +138,12 @@ src_configure() {
$(use_with ssh ssh2) \
$(use_with libxml2) \
$(use_with odbc unixodbc) \
- $(use_with ssl openssl) \
- || die "econf failed"
+ $(use_with ssl openssl)
}
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
- emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
fi
}