summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-09-14 15:18:19 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-09-14 15:23:30 +0300
commit956edd419e62945200693a1fa0425ce0b8295cf0 (patch)
tree367b930883ef45f952884de01ddd59a3dbb28d27 /net-dialup/accel-ppp
parentdev-python/greenlet: fix doc build (diff)
downloadgentoo-956edd419e62945200693a1fa0425ce0b8295cf0.tar.gz
gentoo-956edd419e62945200693a1fa0425ce0b8295cf0.tar.bz2
gentoo-956edd419e62945200693a1fa0425ce0b8295cf0.zip
net-dialup/accel-ppp-9999: migrate from cmake-utils to cmake eclass
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-dialup/accel-ppp')
-rw-r--r--net-dialup/accel-ppp/accel-ppp-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-dialup/accel-ppp/accel-ppp-9999.ebuild b/net-dialup/accel-ppp/accel-ppp-9999.ebuild
index 08a014f0a2b7..3f8aec7348a9 100644
--- a/net-dialup/accel-ppp/accel-ppp-9999.ebuild
+++ b/net-dialup/accel-ppp/accel-ppp-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
EGIT_REPO_URI="https://github.com/accel-ppp/accel-ppp.git"
-inherit cmake-utils flag-o-matic git-r3 linux-info linux-mod
+inherit cmake flag-o-matic git-r3 linux-info linux-mod
DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
HOMEPAGE="https://sourceforge.net/projects/accel-ppp/"
@@ -51,7 +51,7 @@ src_prepare() {
# Bug #549918
append-ldflags -Wl,-z,lazy
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -71,11 +71,11 @@ src_configure() {
-DSHAPER="$(usex shaper)"
$(use debug && echo "-DVALGRIND=$(usex valgrind)")
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
@@ -84,7 +84,7 @@ src_install() {
linux-mod_src_install
fi
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r rfc