summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/mwavem/mwavem-2.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/mwavem/mwavem-2.0-r1.ebuild')
-rw-r--r--net-dialup/mwavem/mwavem-2.0-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-dialup/mwavem/mwavem-2.0-r1.ebuild b/net-dialup/mwavem/mwavem-2.0-r1.ebuild
new file mode 100644
index 000000000000..5c6478f86ae2
--- /dev/null
+++ b/net-dialup/mwavem/mwavem-2.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+AT_M4DIR="m4"
+
+inherit autotools eutils
+
+DESCRIPTION="User level application for IBM Mwave modem"
+HOMEPAGE="http://oss.software.ibm.com/acpmodem/"
+SRC_URI="ftp://www-126.ibm.com/pub/acpmodem/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dosbin "${FILESDIR}/mwave-dev-handler"
+
+ insinto /etc/devfs.d
+ newins "${FILESDIR}/mwave.devfs" mwave
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/mwave.modules" mwave.conf
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README README.devfs THANKS
+ docinto doc
+ dodoc doc/mwave.sgml doc/mwave.txt
+ dohtml doc/mwave.html
+}
+
+pkg_postinst() {
+ # Below is to get /etc/modules.d/mwave loaded into /etc/modules.conf
+ if [ "$ROOT" = "/" ]; then
+ [ -x /sbin/update-modules ] && /sbin/update-modules || /sbin/modules-update
+ fi
+
+ if [ -e "${ROOT}/dev/.devfsd" ]; then
+ # device node is created by devfs
+ ebegin "Restarting devfsd to reread devfs rules"
+ killall -HUP devfsd
+ eend $?
+ elif [ -e "${ROOT}/dev/.udev" ]; then
+ #the device should be created by udev
+ ebegin "Restarting udev to reread udev rules"
+ udevadm control --reload-rules
+ eend $?
+ else
+ [ ! -d "${ROOT}/dev/modem" ] && mkdir --mode=0755 "${ROOT}/dev/modems"
+ mknod --mode=0660 "${ROOT}/dev/modems/mwave" c 10 219
+ fi
+}