summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-12-09 02:00:10 -0500
committerTim Harder <radhermit@gentoo.org>2016-12-09 02:01:23 -0500
commite1592aff6754bfa214bb8f8b5cd8abeea3d6abff (patch)
tree01d7e1572df7594294f5b0c1474dc3beb28adada /net-dialup/picocom/picocom-2.2.ebuild
parentdev-ruby/timecop: add ruby22 (diff)
downloadgentoo-e1592aff6754bfa214bb8f8b5cd8abeea3d6abff.tar.gz
gentoo-e1592aff6754bfa214bb8f8b5cd8abeea3d6abff.tar.bz2
gentoo-e1592aff6754bfa214bb8f8b5cd8abeea3d6abff.zip
net-dialup/picocom: version bump to 2.2
Diffstat (limited to 'net-dialup/picocom/picocom-2.2.ebuild')
-rw-r--r--net-dialup/picocom/picocom-2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/picocom/picocom-2.2.ebuild b/net-dialup/picocom/picocom-2.2.ebuild
new file mode 100644
index 000000000000..9fb2b2291201
--- /dev/null
+++ b/net-dialup/picocom/picocom-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="minimal dumb-terminal emulation program"
+HOMEPAGE="https://github.com/npat-efault/picocom"
+SRC_URI="https://github.com/npat-efault/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_compile() {
+ # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
+ # C++ file, and the pre-processor is never called directly, this
+ # is easier than patching it out.
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin picocom pc{asc,xm,ym,zm}
+ doman picocom.1
+ dodoc CHANGES.old CONTRIBUTORS README.md
+}