summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 16:49:32 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 16:59:32 -0500
commit2a53d01b444833c16785e01d2e466a3c3ea01bd9 (patch)
tree68baa3235c8747cc44d7021d8e8856d720149f4f /net-dialup/pptpd
parentnet-dialup/pptpd: use #!/sbin/openrc-run instead of #!/sbin/runscript (diff)
downloadgentoo-2a53d01b444833c16785e01d2e466a3c3ea01bd9.tar.gz
gentoo-2a53d01b444833c16785e01d2e466a3c3ea01bd9.tar.bz2
gentoo-2a53d01b444833c16785e01d2e466a3c3ea01bd9.zip
net-dialup/pptpd: remove pptpd-1.4.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-dialup/pptpd')
-rw-r--r--net-dialup/pptpd/pptpd-1.4.0.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/net-dialup/pptpd/pptpd-1.4.0.ebuild b/net-dialup/pptpd/pptpd-1.4.0.ebuild
deleted file mode 100644
index 86da5937c32c..000000000000
--- a/net-dialup/pptpd/pptpd-1.4.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Linux Point-to-Point Tunnelling Protocol Server"
-HOMEPAGE="http://poptop.sourceforge.net/"
-SRC_URI="mirror://sourceforge/poptop/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="gre-extreme-debug tcpd"
-
-DEPEND="net-dialup/ppp:=
- tcpd? ( sys-apps/tcp-wrappers )"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-gentoo.patch"
- epatch "${FILESDIR}/${P}-sandbox-fix.patch"
-
- # Match pptpd-logwtmp.so's version with pppd's version (#89895)
- local PPPD_VER=`best_version net-dialup/ppp`
- PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
- PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
- sed -i -e "s:\\(#define[ \\t]*VERSION[ \\t]*\\)\".*\":\\1\"${PPPD_VER}\":" plugins/patchlevel.h || die
-
- # Automake 1.13, compatibility, bug #469476
- sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADER/' configure.in || die 'sed on configure.ac failed'
-
- # remove 'missing' script to prevent warnings
- rm missing || die 'remove missing script failed'
-
- # respect compiler, bug #461722
- tc-export CC
-
- # Apply user patches
- epatch_user
-
- eautoreconf
-}
-
-src_configure() {
- use gre-extreme-debug && append-cppflags "-DLOG_DEBUG_GRE_ACCEPTING_PACKET"
- econf \
- --enable-bcrelay \
- $(use tcpd && echo "--with-libwrap")
-}
-
-src_compile() {
- emake COPTS="${CFLAGS}"
-}
-
-src_install () {
- default
-
- insinto /etc
- doins samples/pptpd.conf
-
- insinto /etc/ppp
- doins samples/options.pptpd
-
- newinitd "${FILESDIR}/pptpd-init-r2" pptpd
- newconfd "${FILESDIR}/pptpd-confd" pptpd
-
- dodoc README.*
- dodoc -r samples
-}