summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-17 20:06:59 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-17 21:19:26 +0200
commit08e048738985e51444a38ebc5222e232c042c00c (patch)
tree5bec9fb3d293c88847fc15d70b4507cdcf59181c /net-dialup
parentmail-mta/ssmtp: drop old version (diff)
downloadgentoo-08e048738985e51444a38ebc5222e232c042c00c.tar.gz
gentoo-08e048738985e51444a38ebc5222e232c042c00c.tar.bz2
gentoo-08e048738985e51444a38ebc5222e232c042c00c.zip
net-dialup/sendpage: migrate to glep 81
Closes: https://bugs.gentoo.org/781371 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/sendpage/sendpage-1.1.0-r4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-dialup/sendpage/sendpage-1.1.0-r4.ebuild b/net-dialup/sendpage/sendpage-1.1.0-r4.ebuild
new file mode 100644
index 000000000000..d64a0d18100e
--- /dev/null
+++ b/net-dialup/sendpage/sendpage-1.1.0-r4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+MY_P=${PN}-1.001
+
+DESCRIPTION="Dialup alphapaging software"
+HOMEPAGE="https://www.sendpage.org/"
+SRC_URI="https://www.sendpage.org/download/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ acct-group/sms
+ acct-user/sendpage
+ dev-perl/DBI
+ dev-perl/Device-SerialPort
+ dev-perl/MailTools
+ dev-perl/Net-SNPP
+ virtual/perl-libnet
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PV}-makefile.patch )
+
+src_install() {
+ perl-module_src_install
+ insinto /etc
+ doins sendpage.cf
+ newinitd "${FILESDIR}"/sendpage.initd sendpage
+ diropts -o sendpage -g sms -m0770
+ keepdir /var/spool/sendpage
+ docompress -x /usr/share/doc/${PF}/text/
+ docinto text/
+ dodoc docs/*
+}