summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Ratiu <adrian.ratiu@collabora.com>2021-02-19 18:46:27 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-02-26 17:53:06 +0100
commit5493d58f7193edba37a56af5f1afdd631554c115 (patch)
treef27ae21f0113c4cf0d6b739a4fc259046973ef4e /net-dialup
parentdev-python/mypy: "Remove old" (diff)
downloadgentoo-5493d58f7193edba37a56af5f1afdd631554c115.tar.gz
gentoo-5493d58f7193edba37a56af5f1afdd631554c115.tar.bz2
gentoo-5493d58f7193edba37a56af5f1afdd631554c115.zip
net-dialup/ppp: add back option to disable eap-tls
The eap-tls use flag went away between ppp-2.4.8 and ppp-2.4.9 maybe due to the fact that upstream now supports eap-tls and has it enabled by default (no more ebuild patches for it). Regardless, having an option to disable it is still useful for those who want to minimize attack vector surface so add it back. Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com> Closes: https://github.com/gentoo/gentoo/pull/19546 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/ppp-2.4.9-r2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-dialup/ppp/ppp-2.4.9-r2.ebuild b/net-dialup/ppp/ppp-2.4.9-r2.ebuild
index ac481c696fb5..6a3902fbd723 100644
--- a/net-dialup/ppp/ppp-2.4.9-r2.ebuild
+++ b/net-dialup/ppp/ppp-2.4.9-r2.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/paulusmack/ppp/archive/${P}.tar.gz
LICENSE="BSD GPL-2"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="activefilter atm dhcp gtk ipv6 libressl pam radius"
+IUSE="activefilter atm dhcp +eap-tls gtk ipv6 libressl pam radius"
DEPEND="
activefilter? ( net-libs/libpcap )
@@ -69,6 +69,14 @@ src_prepare() {
-i pppd/plugins/Makefile.linux || die
fi
+ if ! use eap-tls ; then
+ einfo "Disabling EAP-TLS pppd auth support"
+ sed -i '/^USE_EAPTLS=y/s:^:#:' pppd/Makefile.linux || die
+ einfo "Disabling EAP-TLS plugin support"
+ sed -i '/^CFLAGS += -DUSE_EAPTLS=1/s:^:#:' \
+ pppd/plugins/Makefile.linux || die
+ fi
+
# Set correct libdir
sed -i -e "s:/lib/pppd:/$(get_libdir)/pppd:" \
pppd/{pathnames.h,pppd.8} || die