summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-20 23:46:54 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-20 23:46:54 +0000
commitebc4ea42dfa99e5efe6d30110a40e0bc52970f51 (patch)
treecc2142bc8e15e578f27a395807688cb1ed42d594 /net-dialup
parentsys-kernel/gentoo-sources: stable 4.9.210 for ia64, bug #705006 (diff)
downloadgentoo-ebc4ea42dfa99e5efe6d30110a40e0bc52970f51.tar.gz
gentoo-ebc4ea42dfa99e5efe6d30110a40e0bc52970f51.tar.bz2
gentoo-ebc4ea42dfa99e5efe6d30110a40e0bc52970f51.zip
net-dialup/minicom: tweak for gcc-10, bug #705836
Closes: https://bugs.gentoo.org/705836 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/minicom/files/minicom-2.7.1-gcc-10.patch31
-rw-r--r--net-dialup/minicom/minicom-2.7.1.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/net-dialup/minicom/files/minicom-2.7.1-gcc-10.patch b/net-dialup/minicom/files/minicom-2.7.1-gcc-10.patch
new file mode 100644
index 000000000000..43e057ce1fe8
--- /dev/null
+++ b/net-dialup/minicom/files/minicom-2.7.1-gcc-10.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/705836
+--- a/src/minicom.h
++++ b/src/minicom.h
+@@ -109,13 +109,13 @@ EXTERN char *dial_tty; /* tty to use. */
+
+ EXTERN char *dial_name; /* System we're conneced to */
+ EXTERN char *dial_number; /* Number we've dialed. */
+-EXTERN char *dial_user; /* Our username there */
+-EXTERN char *dial_pass; /* Our password */
++extern char *dial_user; /* Our username there */
++extern char *dial_pass; /* Our password */
+
+ #ifdef USE_SOCKET
+-EXTERN int portfd_is_socket; /* File descriptor is a unix socket */
+-EXTERN int portfd_is_connected; /* 1 if the socket is connected */
+-EXTERN struct sockaddr_un portfd_sock_addr; /* the unix socket address */
++extern int portfd_is_socket; /* File descriptor is a unix socket */
++extern int portfd_is_connected; /* 1 if the socket is connected */
++extern struct sockaddr_un portfd_sock_addr; /* the unix socket address */
+ #define portfd_connected ((portfd_is_socket && !portfd_is_connected) \
+ ? -1 : portfd)
+ #else
+@@ -141,7 +141,7 @@ EXTERN int sbcolor; /* Status Bar Background Color */
+ EXTERN int st_attr; /* Status Bar attributes. */
+
+ /* jl 04.09.97 conversion tables */
+-EXTERN unsigned char vt_outmap[256], vt_inmap[256];
++extern unsigned char vt_outmap[256], vt_inmap[256];
+
+ /* MARK updated 02/17/95 - history buffer */
+ EXTERN int num_hist_lines; /* History buffer size */
diff --git a/net-dialup/minicom/minicom-2.7.1.ebuild b/net-dialup/minicom/minicom-2.7.1.ebuild
index 784ed24db870..818170257cba 100644
--- a/net-dialup/minicom/minicom-2.7.1.ebuild
+++ b/net-dialup/minicom/minicom-2.7.1.ebuild
@@ -25,6 +25,7 @@ S="${WORKDIR}/${PN}-2.7" # 2.7.1 specific
PATCHES=(
"${FILESDIR}"/${PN}-2.3-gentoo-runscript.patch
"${FILESDIR}"/${PN}-2.7-lockdir.patch
+ "${FILESDIR}"/${PN}-2.7.1-gcc-10.patch
)
src_prepare() {