summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-24 11:45:08 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-24 11:45:51 +0200
commit35edd05a5530db10454d9347720e36ae954a20eb (patch)
treeb2a7f061b0bb8e59fc3f385a5c08e5cc9cbd8484 /net-dns/c-ares
parentdev-python/geventhttpclient: fix ImportError while collecting tests (diff)
downloadgentoo-35edd05a5530db10454d9347720e36ae954a20eb.tar.gz
gentoo-35edd05a5530db10454d9347720e36ae954a20eb.tar.bz2
gentoo-35edd05a5530db10454d9347720e36ae954a20eb.zip
net-dns/c-ares: Version 1.15.0
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-dns/c-ares')
-rw-r--r--net-dns/c-ares/Manifest1
-rw-r--r--net-dns/c-ares/c-ares-1.15.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-dns/c-ares/Manifest b/net-dns/c-ares/Manifest
index ec995464d446..6991aca29536 100644
--- a/net-dns/c-ares/Manifest
+++ b/net-dns/c-ares/Manifest
@@ -1,2 +1,3 @@
DIST c-ares-1.13.0.tar.gz 1446797 BLAKE2B 9d7daaad8e35242f110ee8b4abf20619e46beb3fcf49a1b6d7df596fd4129b56cb92f4aeba10845aeb6ed4f4d789ac11745ddc87803ca5bf27fed1aebdb4286c SHA512 4a7942e754673f5b8d55a7471e31b0f390e8324b14c12077580c956147fad4d165c7fe8a3190199b1add95c710ceeb1a7957706d4f0d6299d39c5dddc719bd9d
DIST c-ares-1.14.0.tar.gz 1335940 BLAKE2B d62a0b6d5ea4a2926ff8f2f719d267f9a0c97fa9756b80fcf7c97822f3dd7a1ce9587d9db0ea5217f052f54f5858c68e71c78c33f32fe60df81f456cd9719ac6 SHA512 30cd3f8c4eea15f994b2ceb44d84e506858f69f624e651e39bb4db523fea9ad5e8906b75abf07131ae364be19172274ed4053059669091f21ce4463cdbb857bf
+DIST c-ares-1.15.0.tar.gz 1347687 BLAKE2B c4028bb2840af23274b79c73600bfcf73a348c7ab63ae3c215829e0fe2cf149f4ad38a3ec657c3997bad818ced3cacaed0579dd0dd2ef42eaffd074bdc4f22ed SHA512 a1de6c5e7e1a6a13c926aae690e83d5caa51e7313d63da1cf2af6bc757c41d585aad5466bc3ba7b7f7793cb1748fa589f40972b196728851c8b059cfc8c3be50
diff --git a/net-dns/c-ares/c-ares-1.15.0.ebuild b/net-dns/c-ares/c-ares-1.15.0.ebuild
new file mode 100644
index 000000000000..c90ba00fe1b5
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.15.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.haxx.se/"
+SRC_URI="https://${PN}.haxx.se/download/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE="static-libs"
+
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.12.0-remove-tests.patch
+ eapply_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}