summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-04-19 21:26:37 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-04-19 21:26:54 -0400
commit5b6cc80b2ba5a2ee76cd203379dedb0a1dbe6aae (patch)
tree597abf8c76492b4ec7ba659803c37160ed710a51 /net-dns/djbdns
parentnet-misc/htbinit: port to EAPI 7 (diff)
downloadgentoo-5b6cc80b2ba5a2ee76cd203379dedb0a1dbe6aae.tar.gz
gentoo-5b6cc80b2ba5a2ee76cd203379dedb0a1dbe6aae.tar.bz2
gentoo-5b6cc80b2ba5a2ee76cd203379dedb0a1dbe6aae.zip
net-dns/djbdns: new revision with $AR and $RANLIB support.
Upstream lives on only in our thoughts and prayers, so I patched the Makefile slightly to make this happen. Closes: https://bugs.gentoo.org/784230 Closes: https://bugs.gentoo.org/784233 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-dns/djbdns')
-rw-r--r--net-dns/djbdns/djbdns-1.05-r35.ebuild (renamed from net-dns/djbdns/djbdns-1.05-r34.ebuild)3
-rw-r--r--net-dns/djbdns/files/AR-and-RANLIB-support.patch48
2 files changed, 50 insertions, 1 deletions
diff --git a/net-dns/djbdns/djbdns-1.05-r34.ebuild b/net-dns/djbdns/djbdns-1.05-r35.ebuild
index f2f79e02fd0c..8cc9d5c60aac 100644
--- a/net-dns/djbdns/djbdns-1.05-r34.ebuild
+++ b/net-dns/djbdns/djbdns-1.05-r35.ebuild
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}/increase-cname-recustion-depth.patch"
"${FILESDIR}/CVE2009-0858_0001-check-response-domain-name-length.patch"
"${FILESDIR}/CVE2012-1191_0001-ghost-domain-attack.patch"
+ "${FILESDIR}/AR-and-RANLIB-support.patch"
)
src_prepare() {
@@ -73,7 +74,7 @@ src_compile() {
echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
echo "/usr" > conf-home || die
- emake
+ emake AR=$(tc-getAR) RANLIB=$(tc-getRANLIB)
}
src_install() {
diff --git a/net-dns/djbdns/files/AR-and-RANLIB-support.patch b/net-dns/djbdns/files/AR-and-RANLIB-support.patch
new file mode 100644
index 000000000000..792bc22a82c5
--- /dev/null
+++ b/net-dns/djbdns/files/AR-and-RANLIB-support.patch
@@ -0,0 +1,48 @@
+From 5dde3af17a784615ab52130702458ca83d5b18bd Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 19 Apr 2021 21:11:02 -0400
+Subject: [PATCH 1/1] Makefile: support AR and RANLIB variables.
+
+These variables should default to the generic "ar" and "ranlib"
+commands, but if the user specifies them we now respect them.
+
+Gentoo-bug: https://bugs.gentoo.org/784230
+Gentoo-bug: https://bugs.gentoo.org/784233
+---
+ Makefile | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1429643..5742195 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,8 @@
+ # Don't edit Makefile! Use conf-* for configuration.
+
+ SHELL=/bin/sh
++AR ?= ar
++RANLIB ?= ranlib
+
+ default: it
+
+@@ -581,7 +583,7 @@ warn-auto.sh systype
+ ( cat warn-auto.sh; \
+ echo 'main="$$1"; shift'; \
+ echo 'rm -f "$$main"'; \
+- echo 'ar cr "$$main" $${1+"$$@"}'; \
++ echo '$(AR) cr "$$main" $${1+"$$@"}'; \
+ case "`cat systype`" in \
+ sunos-5.*) ;; \
+ unix_sv*) ;; \
+@@ -590,7 +592,7 @@ warn-auto.sh systype
+ dgux-*) ;; \
+ hp-ux-*) ;; \
+ sco*) ;; \
+- *) echo 'ranlib "$$main"' ;; \
++ *) echo '$(RANLIB) "$$main"' ;; \
+ esac \
+ ) > makelib
+ chmod 755 makelib
+--
+2.26.3
+