summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/dnscap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/dnscap')
-rw-r--r--net-dns/dnscap/Manifest1
-rw-r--r--net-dns/dnscap/dnscap-20130814.ebuild30
-rw-r--r--net-dns/dnscap/files/dnscap-20130814.install.patch22
-rw-r--r--net-dns/dnscap/metadata.xml12
4 files changed, 65 insertions, 0 deletions
diff --git a/net-dns/dnscap/Manifest b/net-dns/dnscap/Manifest
new file mode 100644
index 000000000000..511920621071
--- /dev/null
+++ b/net-dns/dnscap/Manifest
@@ -0,0 +1 @@
+DIST dnscap-20130814.tar.gz 99615 SHA256 17c367e6697d6e93eb4ebf0ac038e10eb6950c75a9890c914ba0f7a0f9c2500e SHA512 1969d8cc47c6206369a02b29064dbb7f663a2187203ab1f49d862082bfb6e44c9fccf90fb63d65a523c7a5cf4d24815a74b9dd18d81267b4447252d7a04f33dd WHIRLPOOL 888d7544525901974b5b501cf4feb842363da95b50ed48dda0276dc5c733de8510c65f9942b72ffb4d9c43ac8f0ca2cf12154525c2fd40561a4fec81a7aee598
diff --git a/net-dns/dnscap/dnscap-20130814.ebuild b/net-dns/dnscap/dnscap-20130814.ebuild
new file mode 100644
index 000000000000..b1a1dd7a4769
--- /dev/null
+++ b/net-dns/dnscap/dnscap-20130814.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="dnscap is a network capture utility designed specifically for DNS traffic"
+HOMEPAGE="http://dnscap.dns-oarc.net/"
+
+## github commit tarball
+MY_GIT_COMMIT="727ed7d5e46625abc2c8d988689a300589e948b6"
+MY_P="verisign-${PN}-${MY_GIT_COMMIT:0:7}"
+SRC_URI="https://github.com/verisign/${PN}/tarball/${MY_GIT_COMMIT} -> ${PF}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="ISC"
+IUSE=""
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ ## adds DESTDIR to install target
+ epatch "${FILESDIR}/${P}.install.patch"
+}
diff --git a/net-dns/dnscap/files/dnscap-20130814.install.patch b/net-dns/dnscap/files/dnscap-20130814.install.patch
new file mode 100644
index 000000000000..b09c7cfdbfcf
--- /dev/null
+++ b/net-dns/dnscap/files/dnscap-20130814.install.patch
@@ -0,0 +1,22 @@
+diff -urN verisign-dnscap-727ed7d.orig/Makefile.in verisign-dnscap-727ed7d/Makefile.in
+--- verisign-dnscap-727ed7d.orig/Makefile.in 2013-08-14 01:31:33.000000000 +0200
++++ verisign-dnscap-727ed7d/Makefile.in 2014-04-26 22:04:35.438580361 +0200
+@@ -45,13 +45,11 @@
+ all: ${prog} ${prog}.cat1
+
+ install: all
+- install -d -m 755 ${bindir}
+- if [ -f ${bindir}/${prog} ]; then \
+- mv -f ${bindir}/${prog} ${bindir}/${prog}.old; fi
+- install -m 755 ${prog} ${bindir}/
+- install -d -m 755 ${mandir}
+- install -d -m 755 ${mandir}/cat1
+- install -m 644 ${prog}.cat1 ${mandir}/cat1/${prog}.1
++ install -d -m 755 $(DESTDIR)${bindir}
++ install -m 755 ${prog} $(DESTDIR)${bindir}/
++ install -d -m 755 $(DESTDIR)${mandir}
++ install -d -m 755 $(DESTDIR)${mandir}/cat1
++ install -m 644 ${prog}.cat1 $(DESTDIR)${mandir}/cat1/${prog}.1
+
+ .c.o:
+ ${CC} ${CFLAGS} -c $<
diff --git a/net-dns/dnscap/metadata.xml b/net-dns/dnscap/metadata.xml
new file mode 100644
index 000000000000..68838f5ff96d
--- /dev/null
+++ b/net-dns/dnscap/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">verisign/dnscap</remote-id>
+ </upstream>
+</pkgmetadata>