summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-22 14:42:07 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-10-22 14:45:32 +0200
commit0a1505c64ea80a4ed92dc7c478230233773abb93 (patch)
tree4c8f4c48230b3b71dde80b5550898c3a69ab3ef3 /net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0.ebuild
parenteclass: fix missing DESCRIPTION in docstring (diff)
downloadgentoo-0a1505c64ea80a4ed92dc7c478230233773abb93.tar.gz
gentoo-0a1505c64ea80a4ed92dc7c478230233773abb93.tar.bz2
gentoo-0a1505c64ea80a4ed92dc7c478230233773abb93.zip
net-dns/dnscrypt-proxy: version bump to 1.6.0 and various fixes
* remove unused eutils inherit * fix dependency on sys-apps/systemd (it's not just RDEPEND) * add missing DEPEND on virtual/pkgconfig * remove automagic dependency on ldns to avoid dependency breakage and depend on it unconditionally (there is no build-system switch) * don't install COPYING, it's already in LICENSE variable, also simplify DOCS string * add pkg_postinst() information on usage * minor cosmetic changes
Diffstat (limited to 'net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0.ebuild')
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0.ebuild
new file mode 100644
index 000000000000..1957f9fdab53
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit systemd user
+
+DESCRIPTION="A tool for securing communications between a client and a DNS resolver"
+HOMEPAGE="http://dnscrypt.org/"
+SRC_URI="http://download.dnscrypt.org/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins systemd"
+
+CDEPEND="
+ dev-libs/libsodium
+ net-libs/ldns
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README* TECHNOTES THANKS"
+
+pkg_setup() {
+ enewgroup dnscrypt
+ enewuser dnscrypt -1 -1 /var/empty dnscrypt
+}
+
+src_configure() {
+ econf \
+ $(use_enable plugins) \
+ $(use_with systemd)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver <DNSCRYPT_LOCALIP>"
+ elog
+ elog "where <DNSCRYPT_LOCALIP> is what you supplied in"
+ elog "/etc/conf.d/dnscrypt-proxy, default is \"127.0.0.1\"."
+ elog
+ elog "Also see https://github.com/jedisct1/dnscrypt-proxy#usage."
+}