summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbgo <bgo@9dt.de>2017-06-13 15:14:27 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-14 09:48:43 +0200
commite5a542cc6b37b5cc2f02c228118ec9db7a0bba3a (patch)
tree35174c883706f5ee65872d1c9b252cea2cb7d7b2 /net-dns/dnsdist/dnsdist-9999.ebuild
parentsys-cluster/teleport: new package, #620054 (diff)
downloadgentoo-e5a542cc6b37b5cc2f02c228118ec9db7a0bba3a.tar.gz
gentoo-e5a542cc6b37b5cc2f02c228118ec9db7a0bba3a.tar.bz2
gentoo-e5a542cc6b37b5cc2f02c228118ec9db7a0bba3a.zip
net-dns/dnsdist: drop readline support
Closes: https://github.com/gentoo/gentoo/pull/4921
Diffstat (limited to 'net-dns/dnsdist/dnsdist-9999.ebuild')
-rw-r--r--net-dns/dnsdist/dnsdist-9999.ebuild21
1 files changed, 3 insertions, 18 deletions
diff --git a/net-dns/dnsdist/dnsdist-9999.ebuild b/net-dns/dnsdist/dnsdist-9999.ebuild
index a05714220961..10e8fc265847 100644
--- a/net-dns/dnsdist/dnsdist-9999.ebuild
+++ b/net-dns/dnsdist/dnsdist-9999.ebuild
@@ -24,17 +24,15 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="dnscrypt luajit readline regex remote-logging snmp +ssl test"
-RESTRICT="readline? ( bindist )"
+IUSE="dnscrypt luajit regex remote-logging snmp +ssl test"
REQUIRED_USE="dnscrypt? ( ssl )"
DEPEND="
>=dev-libs/boost-1.35:=
+ dev-libs/libedit:=
luajit? ( dev-lang/luajit:= )
!luajit? ( >=dev-lang/lua-5.1:= )
remote-logging? ( dev-libs/protobuf:= )
- readline? ( sys-libs/readline:0= )
- !readline? ( dev-libs/libedit:= )
regex? ( dev-libs/re2:= )
snmp? ( net-analyzer/net-snmp:= )
ssl? ( dev-libs/libsodium:= )
@@ -48,19 +46,11 @@ RDEPEND="${DEPEND}"
"
src_prepare() {
- eapply "${FILESDIR}/${PN}-readline.patch"
- eapply_user
-
+ default
[[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
- if use readline ; then
- local -x LIBEDIT_CFLAGS="-I/usr/include/readline"
- local -x LIBEDIT_LIBS="-lreadline -lcurses"
- append-cxxflags -DREADLINE
- fi
-
econf \
--sysconfdir=/etc/dnsdist \
$(use_enable ssl libsodium) \
@@ -93,9 +83,4 @@ pkg_postinst() {
elog
elog "The name must be in the format dnsdist.<suffix> and dnsdist will use the"
elog "/etc/dnsdist/dnsdist-<suffix>.conf configuration file instead of the default."
-
- if use readline ; then
- ewarn "dnsdist (GPLv2) was linked against readline (GPLv3)."
- ewarn "A binary distribution should therefore not happen."
- fi
}