summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2020-07-31 10:12:13 +0200
committerAndreas Schuerch <nativemad@gentoo.org>2020-07-31 10:13:21 +0200
commitb7fb560859a6a7f42ec0517ec2ee19e5f1f99172 (patch)
tree3514832da92a5397c413bce59e0e7939f107bbbc /net-dns/dnsdist
parentapp-text/calibre: Bump to version 4.22.0 (diff)
downloadgentoo-b7fb560859a6a7f42ec0517ec2ee19e5f1f99172.tar.gz
gentoo-b7fb560859a6a7f42ec0517ec2ee19e5f1f99172.tar.bz2
gentoo-b7fb560859a6a7f42ec0517ec2ee19e5f1f99172.zip
net-dns/dnsdist: version bump to 1.5.0 and bug 711454
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
Diffstat (limited to 'net-dns/dnsdist')
-rw-r--r--net-dns/dnsdist/Manifest1
-rw-r--r--net-dns/dnsdist/dnsdist-1.5.0.ebuild84
-rw-r--r--net-dns/dnsdist/files/dnsdist.initd5
3 files changed, 88 insertions, 2 deletions
diff --git a/net-dns/dnsdist/Manifest b/net-dns/dnsdist/Manifest
index c3750fa2697f..6d2a06fbff8c 100644
--- a/net-dns/dnsdist/Manifest
+++ b/net-dns/dnsdist/Manifest
@@ -1,2 +1,3 @@
DIST dnsdist-1.3.3.tar.bz2 971253 BLAKE2B e9c36969fc1e4b95b71a3f6885503aea2d527b4d9abce9cb137c290a21aee994a441c0e17c0bf985396fda51020b5ef910753554990259abb16641d93d2d1010 SHA512 c0e3435eafc1f7bcdf41346cecf7b089cc142716f94058f9ec262d0c6ad16467e0b8bed5abc648829c597120c94f998602849ded574e75bfc1a1fb70c1b719ad
DIST dnsdist-1.4.0.tar.bz2 1044479 BLAKE2B 79aef57ed2b1036f222e8bcfdf615c3221c9dfdbc8fd3f80d778fb050f74bc200958b4d605dcadd5c23ac6c4b5b1a36048108cd85394920e99d6037177b81342 SHA512 c9450e97325d8ad8c8c3a395412c46ea8053cbe1ebe73329a1618212ba29bdf2f8da908ae2b90c314b5aab613387f42363e3a5322b1a36f60190fb48e1c425c5
+DIST dnsdist-1.5.0.tar.bz2 1067645 BLAKE2B de07de8f862a633d8eb11ccf632e01c2ce779a35ef61ba2fcf932894d692f2f3edfd638ce77f178bbfbfc1115d8e76f5522e10061fcf61650170a5b59d5cc9ca SHA512 df6f8caae001f152f0d264176c570778842979484d16e4199afe0e2591006392444245dd8ce23287cdcf9613e2c40a9e3564f5236e5f5a6fd67b89d6ea0d9ed4
diff --git a/net-dns/dnsdist/dnsdist-1.5.0.ebuild b/net-dns/dnsdist/dnsdist-1.5.0.ebuild
new file mode 100644
index 000000000000..b36be988dc3b
--- /dev/null
+++ b/net-dns/dnsdist/dnsdist-1.5.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A highly DNS-, DoS- and abuse-aware loadbalancer"
+HOMEPAGE="https://dnsdist.org"
+
+SRC_URI="https://downloads.powerdns.com/releases/${P}.tar.bz2"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dnscrypt dnstap doh gnutls +lmdb luajit regex remote-logging snmp +ssl systemd test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="dnscrypt? ( ssl )
+ gnutls? ( ssl )
+ doh? ( ssl !gnutls )"
+
+RDEPEND="acct-group/dnsdist
+ acct-user/dnsdist
+ >=dev-libs/boost-1.35:=
+ dev-libs/libedit:=
+ dnscrypt? ( dev-libs/libsodium:= )
+ dnstap? ( dev-libs/fstrm:= )
+ doh? ( www-servers/h2o:=[libh2o] )
+ lmdb? ( dev-db/lmdb:= )
+ luajit? ( dev-lang/luajit:= )
+ !luajit? ( >=dev-lang/lua-5.1:= )
+ regex? ( dev-libs/re2:= )
+ remote-logging? ( >=dev-libs/protobuf-3:= )
+ snmp? ( net-analyzer/net-snmp:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+ systemd? ( sys-apps/systemd:0= )
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/dnsdist \
+ $(use_enable doh dns-over-https) \
+ $(use_enable dnscrypt) \
+ $(use_enable dnstap) \
+ $(use_with lmdb ) \
+ $(use luajit && echo "--with-lua=luajit" || echo "--with-lua=lua" ) \
+ $(use_with regex re2) \
+ $(use_with remote-logging protobuf) \
+ $(use_with snmp net-snmp) \
+ $(use ssl && { echo "--enable-dns-over-tls" && use_with gnutls && use_with !gnutls libssl;} || echo "--without-gnutls --without-libssl") \
+ $(use_enable systemd) \
+ $(use_enable test unit-tests)
+ sed 's/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl$libdir'\''/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl\/$libdir'\''/g' \
+ -i "${S}/configure"
+}
+
+src_install() {
+ default
+
+ insinto /etc/dnsdist
+ doins "${FILESDIR}"/dnsdist.conf.example
+
+ newconfd "${FILESDIR}"/dnsdist.confd ${PN}
+ newinitd "${FILESDIR}"/dnsdist.initd ${PN}
+}
+
+pkg_postinst() {
+ elog "dnsdist provides multiple instances support. You can create more instances"
+ elog "by symlinking the dnsdist init script to another name."
+ elog
+ elog "The name must be in the format dnsdist.<suffix> and dnsdist will use the"
+ elog "/etc/dnsdist/dnsdist-<suffix>.conf configuration file instead of the default."
+}
diff --git a/net-dns/dnsdist/files/dnsdist.initd b/net-dns/dnsdist/files/dnsdist.initd
index f15a6d9e6a48..554c43b0150a 100644
--- a/net-dns/dnsdist/files/dnsdist.initd
+++ b/net-dns/dnsdist/files/dnsdist.initd
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
extra_commands="configcheck"
@@ -31,7 +31,8 @@ start() {
ebegin "Starting dnsdist (${DNSDIST_INSTANCE})"
start-stop-daemon --start --exec $DNSDIST --pidfile ${PIDFILE} \
- -b -- --supervised -u ${DNSDIST_USER} -g ${DNSDIST_GROUP} \
+ -b -m -- --supervised -u ${DNSDIST_USER} -g
+${DNSDIST_GROUP} \
-C $DNSDIST_CONFFILE ${DNSDIST_OPTIONS}
eend $?
}