summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-11-21 17:11:29 +0100
committerMichael Weber <xmw@gentoo.org>2016-11-21 17:11:29 +0100
commit0cfa6146a1621e772c3dbbc1a5be2573fb424518 (patch)
treee8045326e4452cb109de04c916fdf0a20d8112fb /net-dns/dnstop/dnstop-20140915-r2.ebuild
parentdev-vcs/tortoisehg: Don't use dohtml with EAPI-6. (diff)
downloadgentoo-0cfa6146a1621e772c3dbbc1a5be2573fb424518.tar.gz
gentoo-0cfa6146a1621e772c3dbbc1a5be2573fb424518.tar.bz2
gentoo-0cfa6146a1621e772c3dbbc1a5be2573fb424518.zip
net-dns/dnstop: fix net-libs/libpcap[ipv6] situation, drop USE=ipv6, use pkg-config for ncurses[tinfo] (thanks lorem_ipsum and b4b1@free.fr, bug 595184).
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-dns/dnstop/dnstop-20140915-r2.ebuild')
-rw-r--r--net-dns/dnstop/dnstop-20140915-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-dns/dnstop/dnstop-20140915-r2.ebuild b/net-dns/dnstop/dnstop-20140915-r2.ebuild
new file mode 100644
index 000000000000..ba7c1cca6a9b
--- /dev/null
+++ b/net-dns/dnstop/dnstop-20140915-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Displays various tables of DNS traffic on your network"
+HOMEPAGE="http://dnstop.measurement-factory.com/"
+SRC_URI="http://dnstop.measurement-factory.com/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0
+ net-libs/libpcap[ipv6(+)]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}"-pkg-config.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-ipv6
+}
+
+src_install() {
+ dobin dnstop
+ doman dnstop.8
+ dodoc CHANGES
+}