summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-09-26 13:46:41 +0200
committerMichael Weber <xmw@gentoo.org>2016-09-26 13:47:51 +0200
commitdd10ed8f733239e09ebe82949e68a9c36ad8b37a (patch)
treebbfc9cd5fc49808e1262ac749b637d1fd804d620 /net-dns/dnstop
parentdev-libs/openssl: Sec bump to versions 1.0.2j and 1.1.0b (bug #595186). (diff)
downloadgentoo-dd10ed8f733239e09ebe82949e68a9c36ad8b37a.tar.gz
gentoo-dd10ed8f733239e09ebe82949e68a9c36ad8b37a.tar.bz2
gentoo-dd10ed8f733239e09ebe82949e68a9c36ad8b37a.zip
net-dns/dnstop: Fix for ncurses[tinfo], thanks Fabio Scaccabarozzi, bug 595068.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-dns/dnstop')
-rw-r--r--net-dns/dnstop/dnstop-20140915-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-dns/dnstop/dnstop-20140915-r1.ebuild b/net-dns/dnstop/dnstop-20140915-r1.ebuild
new file mode 100644
index 000000000000..cb7eeef2520d
--- /dev/null
+++ b/net-dns/dnstop/dnstop-20140915-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Displays various tables of DNS traffic on your network"
+HOMEPAGE="http://dnstop.measurement-factory.com/"
+SRC_URI="http://dnstop.measurement-factory.com/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="ipv6"
+
+RDEPEND="sys-libs/ncurses:0
+ net-libs/libpcap[ipv6?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ if has_version sys-libs/ncurses:0[tinfo] ; then
+ append-libs -ltinfo #bug 595068
+ fi
+ econf \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ dobin dnstop
+ doman dnstop.8
+ dodoc CHANGES
+}