summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-30 08:03:26 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-30 08:03:26 +0200
commit28c277788b15e74f38f4ca85416c3ad9575b4fe0 (patch)
tree2c6151d8bccfa3e2850b87241f1ba66b28a95062 /net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild
parentnet-analyzer/namebench: Revbump post dep changes (diff)
downloadgentoo-28c277788b15e74f38f4ca85416c3ad9575b4fe0.tar.gz
gentoo-28c277788b15e74f38f4ca85416c3ad9575b4fe0.tar.bz2
gentoo-28c277788b15e74f38f4ca85416c3ad9575b4fe0.zip
net-dns/hash-slinger: Revbump post dep changes
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild')
-rw-r--r--net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild b/net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild
new file mode 100644
index 000000000000..a2ff821691bc
--- /dev/null
+++ b/net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Various tools to generate special DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
+HOMEPAGE="https://people.redhat.com/pwouters/hash-slinger/"
+SRC_URI="https://people.redhat.com/pwouters/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipsec +openpgp +ssh"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/dnspython[$PYTHON_USEDEP]
+ dev-python/ipaddr[$PYTHON_USEDEP]
+ dev-python/m2crypto[$PYTHON_USEDEP]
+ net-dns/unbound[python,$PYTHON_USEDEP]
+ ipsec? ( net-vpn/libreswan[dnssec] )
+ openpgp? ( dev-python/python-gnupg[$PYTHON_USEDEP] )
+ ssh? ( net-misc/openssh )
+"
+
+src_install() {
+ local tools
+ tools="tlsa"
+ use ssh && tools+=" sshfp"
+ use openpgp && tools+=" openpgpkey"
+ use ipsec && tools+=" ipseckey"
+ for tool in $tools ; do
+ doman ${tool}.1
+ python_foreach_impl python_doscript ${tool}
+ done
+ dodoc BUGS CHANGES README
+}