summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch')
-rw-r--r--net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch b/net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch
new file mode 100644
index 000000000000..7e611c042bee
--- /dev/null
+++ b/net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch
@@ -0,0 +1,58 @@
+--- Makefile.in 2006-03-30 18:22:39.000000000 +0200
++++ Makefile.in 2010-03-12 21:34:34.000000000 +0100
+@@ -22,7 +22,7 @@
+ all: hesinfo
+
+ hesinfo: hesinfo.o
+- ${CC} ${LDFLAGS} -o $@ hesinfo.o -lhesiod ${LIBS}
++ ${CC} ${LDFLAGS} -o $@ hesinfo.o -lhesiod ${LIBS} ${LDFLAGS}
+
+ .c.o:
+ ${CC} -c ${ALL_CFLAGS} $<
+--- configure.in 2006-03-30 18:22:39.000000000 +0200
++++ configure.in 2010-03-12 21:42:05.000000000 +0100
+@@ -7,6 +7,43 @@
+ AC_PROG_CC
+ AC_PROG_INSTALL
+
+-ATHENA_HESIOD_REQUIRED
++dnl This file provides local macros for packages which use specific
++dnl external libraries. The public macros are:
++dnl
++dnl ATHENA_HESIOD_REQUIRED
++dnl Generates error if Hesiod not found.
++dnl Specify desired AFS libraries as a parameter.
++dnl ----- Hesiod -----
++
++AC_DEFUN(ATHENA_HESIOD_CHECK,
++[AC_CHECK_FUNC(res_send, :, AC_CHECK_LIB(resolv, res_send))
++if test "$hesiod" != yes; then
++ CPPFLAGS="$CPPFLAGS -I$hesiod/include"
++ LDFLAGS="$LDFLAGS -L$hesiod/lib"
++fi
++AC_CHECK_LIB(hesiod, hes_resolve, :,
++ [AC_MSG_ERROR(Hesiod library not found)])])
++
++AC_DEFUN(ATHENA_HESIOD,
++[AC_ARG_WITH(hesiod,
++ [ --with-hesiod=PREFIX Use Hesiod],
++ [hesiod="$withval"], [hesiod=no])
++if test "$hesiod" != no; then
++ ATHENA_HESIOD_CHECK
++ HESIOD_LIBS="-lhesiod"
++ AC_DEFINE(HAVE_HESIOD)
++fi
++AC_SUBST(HESIOD_LIBS)])
+
++AC_DEFUN(ATHENA_HESIOD_REQUIRED,
++[AC_ARG_WITH(hesiod,
++ [ --with-hesiod=PREFIX Specify location of Hesiod],
++ [hesiod="$withval"], [hesiod=yes])
++if test "$hesiod" != no; then
++ ATHENA_HESIOD_CHECK
++else
++ AC_MSG_ERROR(This package requires Hesiod.)
++fi])
++
++ATHENA_HESIOD_REQUIRED
+ AC_OUTPUT(Makefile)