summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/host
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/host')
-rw-r--r--net-dns/host/Manifest1
-rw-r--r--net-dns/host/files/host-20070128-Makefile.patch62
-rw-r--r--net-dns/host/host-20070128-r1.ebuild42
-rw-r--r--net-dns/host/metadata.xml7
4 files changed, 112 insertions, 0 deletions
diff --git a/net-dns/host/Manifest b/net-dns/host/Manifest
new file mode 100644
index 000000000000..44d34daa540a
--- /dev/null
+++ b/net-dns/host/Manifest
@@ -0,0 +1 @@
+DIST host-20070128.tar.gz 152347 SHA256 a2a56ab236f9e8549366175a3055e0dc7758dafd46658ed8bea58d87de39bd9f SHA512 80f4d4878af40c93f33cc6c43d19b01415e66b3939b157544b4921b9f0b83ef1baa9ce0e151d951417be92973c4b038df80efae974be4bca2bbce43299db65fc WHIRLPOOL 7072f75f1f39b25375f38387625ced95469f7baeeed069429718a5cb438ee0751a612e3ac0f76e91af9ca653ebe97487476dac2cdaeb1d1fc21a49d67ba62527
diff --git a/net-dns/host/files/host-20070128-Makefile.patch b/net-dns/host/files/host-20070128-Makefile.patch
new file mode 100644
index 000000000000..931c4389db1d
--- /dev/null
+++ b/net-dns/host/files/host-20070128-Makefile.patch
@@ -0,0 +1,62 @@
+--- Makefile.orig 2003-06-05 03:01:45.000000000 +0200
++++ Makefile 2010-03-12 18:53:17.000000000 +0100
+@@ -117,16 +117,11 @@
+ # Compilation definitions.
+ # ----------------------------------------------------------------------
+
+-DEBUGDEFS = -DDEBUG
+
+ DEFS = $(CONFIGDEFS) $(DEBUGDEFS) $(SYSDEFS) $(INCLUDES)
+
+-COPTS = -pipe
+
+-COPTIM = -O2
+-COPTIM = -O
+
+-CDEBUG = -g
+
+ # GCC lint-like warnings -- any warnings are likely bugs in the
+ # platform headers or in gcc itself....
+@@ -139,7 +134,6 @@
+ -Wswitch \
+ -Wcomment \
+ -Wcast-qual \
+- -Wid-clash-30 \
+ -Wpointer-arith \
+ -Wshadow
+ #endif
+@@ -147,7 +141,6 @@
+ #if $(__GNULD__) >= 1
+ GNULDWARNFLAGS = -W \
+ -Wall \
+- -Wid-clash-30
+ #endif
+
+ #if $(__GNUC__) >= 2
+@@ -169,7 +162,7 @@
+ #endif
+
+ CPPFLAGS = $(DEFS)
+-CFLAGS = $(COPTS) $(CDEBUG) $(COPTIM) $(GCCWARNFLAGS) $(GCC2WARNFLAGS) $(GCC3WARNFLAGS)
++CFLAGS += $(GCCWARNFLAGS) $(GCC2WARNFLAGS) $(GCC3WARNFLAGS)
+
+ # Select your favorite compiler if make doesn't already know it...
+ #if defined(next)
+@@ -250,7 +243,7 @@
+ # Unfortunately SunOS-5.9 has only libresolv.so !!!
+ #
+ #if defined(NEED_LIBRESOLV) && !defined(sunos5.x) && !(BIND-8.4.x)
+-LDFLAGS = -static $(GNULDWARNFLAGS)
++LDFLAGS += $(GNULDWARNFLAGS)
+ #else
+ #LDFLAGS = $(GNULDWARNFLAGS)
+ #endif
+@@ -294,7 +287,7 @@
+ # ----------------------------------------------------------------------
+
+ BINOWN = root
+-BINGRP = staff
++BINGRP = root
+ BINMODE = 755
+ #STRIPFLAG = -s
+
diff --git a/net-dns/host/host-20070128-r1.ebuild b/net-dns/host/host-20070128-r1.ebuild
new file mode 100644
index 000000000000..8673e8e03813
--- /dev/null
+++ b/net-dns/host/host-20070128-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A powerful command-line DNS query and test tool implementing many additional protocols"
+HOMEPAGE="http://www.weird.com/~woods/projects/host.html"
+SRC_URI="ftp://ftp.weird.com/pub/Planix/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 sparc x86"
+IUSE="debug"
+
+# Bug 91515
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed -i -e "s:^\(# if defined(__alpha).*\):\1 || defined(__x86_64__):" \
+ port.h || die "sed failed"
+}
+
+src_compile() {
+ use debug && export DEBUGDEFS="-DDEBUG"
+ emake CC="$(tc-getCC)" RES_LIB=/usr/$(get_libdir)/libresolv.a || die "emake failed"
+}
+
+src_install () {
+ # This tool has slightly different format of output from "standard" host.
+ # Renaming it to host-woods, hopefully this does not conflict with anything.
+
+ newbin host host-woods || die "newbin failed"
+ newman host.1 host-woods.1 || die "newman failed"
+ dodoc RELEASE_NOTES ToDo || die "dodoc failed"
+}
diff --git a/net-dns/host/metadata.xml b/net-dns/host/metadata.xml
new file mode 100644
index 000000000000..681873710b63
--- /dev/null
+++ b/net-dns/host/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>george@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>