summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-12-21 15:37:00 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2016-12-21 15:38:44 +0100
commitcae976164ebd9191be909cf57f40992760f6a04a (patch)
tree0b9de17fddc25d0f18ecd921b4a47125106d32d7 /net-dns/ldns-utils/ldns-utils-1.7.0.ebuild
parentnet-libs/ldns: bump version (diff)
downloadgentoo-cae976164ebd9191be909cf57f40992760f6a04a.tar.gz
gentoo-cae976164ebd9191be909cf57f40992760f6a04a.tar.bz2
gentoo-cae976164ebd9191be909cf57f40992760f6a04a.zip
net-dns/ldns-utils: bump version
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-dns/ldns-utils/ldns-utils-1.7.0.ebuild')
-rw-r--r--net-dns/ldns-utils/ldns-utils-1.7.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-dns/ldns-utils/ldns-utils-1.7.0.ebuild b/net-dns/ldns-utils/ldns-utils-1.7.0.ebuild
new file mode 100644
index 000000000000..e051712aee76
--- /dev/null
+++ b/net-dns/ldns-utils/ldns-utils-1.7.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${P/-utils}
+
+DESCRIPTION="Set of utilities to simplify various dns(sec) tasks"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/ldns/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+dane ecdsa examples gost ssl"
+
+DEPEND=">=net-libs/ldns-${PV}[dane?,ecdsa?,gost?,ssl?]
+ examples? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ cd "${S}"/drill
+ econf $(use_with ssl)
+
+ if use examples; then
+ cd "${S}"/examples
+ econf \
+ $(use_enable dane) \
+ $(use_enable ecdsa) \
+ $(use_enable gost) \
+ $(use_enable ssl sha2) \
+ $(use_with ssl)
+ fi
+}
+
+src_compile() {
+ emake -C drill
+ if use examples; then
+ emake -C examples
+ fi
+}
+
+src_install() {
+ cd "${S}"/drill
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog.22-nov-2005 README REGRESSIONS
+
+ if use examples; then
+ cd "${S}"/examples
+ emake DESTDIR="${D}" install
+ newdoc README README.examples
+ fi
+}